Bug 1420447 - OCP HA fails at 90%: "error: No nodes found"
Summary: OCP HA fails at 90%: "error: No nodes found"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: Installation - OpenShift
Version: 1.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 1.1
Assignee: Dylan Murray
QA Contact: Antonin Pagac
Derek
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-08 16:37 UTC by Antonin Pagac
Modified: 2017-02-28 01:46 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-28 01:46:02 UTC
Target Upstream Version:


Attachments (Terms of Use)
ansible.log (8.15 MB, text/plain)
2017-02-08 16:37 UTC, Antonin Pagac
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:0335 normal SHIPPED_LIVE Red Hat Quickstart Installer 1.1 2017-02-28 06:36:13 UTC

Description Antonin Pagac 2017-02-08 16:37:03 UTC
Created attachment 1248640 [details]
ansible.log

Description of problem:
Doing OCP HA on freshly installed Satellite on baremetal env. From ansible.log:

'2017-02-08 11:12:30,383 p=26963 u=foreman |  TASK [Enable scheduling for master] ********************************************
2017-02-08 11:12:30,777 p=26963 u=foreman |  fatal: [ocpha-ocp-master1.example.com]: FAILED! => {"changed": true, "cmd": ["oadm", "manage-node", "[uocpha-ocp-master1.example.com,", "uocpha-ocp-master2.example.com,", "uocpha-ocp-master3.example.com]", "--schedulable"], "delta": "0:00:00.171007", "end": "2017-02-08 11:12:29.680184", "failed": true, "rc": 1, "start": "2017-02-08 11:12:29.509177", "stderr": "error: No nodes found", "stdout": "", "stdout_lines": [], "warnings": []}'

I tried to resume the task, it failed with the same error.

Version-Release number of selected component (if applicable):
QCI-1.1-RHEL-7-20170207.t.0

How reproducible:
Unsure, happened to me once

Steps to Reproduce:
1. Do a deployment of OCP HA on baremetal env and freshly installed Satellite
2. At 90%, the deployment fails
3.

Actual results:
Deployment fails at 90%

Expected results:
Deployment successful

Additional info:

Comment 1 Dylan Murray 2017-02-08 17:11:09 UTC
Looks like ansible didn't like the fix for this as it is converting strings improperly.

Comment 3 Dylan Murray 2017-02-08 20:47:59 UTC
https://github.com/fusor/ansible-ocp/pull/19

Comment 5 Antonin Pagac 2017-02-10 13:06:45 UTC
Verified in QCI-1.1-RHEL-7-20170209.t.0.

Comment 7 errata-xmlrpc 2017-02-28 01:46:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:0335


Note You need to log in before you can comment on or make changes to this bug.