Bug 1420531 - Fabric CTR mode needs counter parameter, not IV
Summary: Fabric CTR mode needs counter parameter, not IV
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: fabric
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Othman Madjoudj
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-08 22:00 UTC by Gregor Simm
Modified: 2017-02-09 16:39 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-09 16:39:55 UTC
Type: Bug


Attachments (Terms of Use)
Upstream patch (1.03 KB, patch)
2017-02-09 15:36 UTC, Thomas Jarosch
no flags Details | Diff

Description Gregor Simm 2017-02-08 22:00:27 UTC
Description of problem:
Update of python2-crypto.x86_64 2.6.1 release 13.el7 breaks fabric.noarch 1.6.2 release 1.el7.
When fabric is executed an error is thrown:
CTR mode needs counter parameter, not IV

Version-Release number of selected component (if applicable):
fabric.noarch 1.6.2 release 1.el7.

How reproducible:

Steps to Reproduce:
1. Run fab program: fab -P -H host xyz

Actual results:
Task xyz is not being executed on host.
An error is thrown:
CTR mode needs counter parameter, not IV

Expected results:
Successful execution of program xyz on host.

Additional info:
This issue is known to the developers and has been fixed in recent versions.
Therefore, an update of fabric to a later version may resolve this issue.

Comment 1 Othman Madjoudj 2017-02-08 22:12:46 UTC
Could you please update python-paramiko to 1.16.1-2.el7 , it should be in updates-testing repo.

https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-31dd41cd3e

Comment 2 Thomas Jarosch 2017-02-09 15:32:54 UTC
if updating python-paramiko to a new release is too fragile,
there's a single line patch to fix the issue:

https://github.com/paramiko/paramiko/pull/714/commits/4752287a7379da61245087ee7e35635a4e42bb3f

Comment 3 Thomas Jarosch 2017-02-09 15:36:08 UTC
Created attachment 1248840 [details]
Upstream patch

Patch from upstream paramiko git repo to fix the issue.

Looks like the new python2-crypto version has a stricter sanity check for the CTR mode.

Comment 4 Gregor Simm 2017-02-09 16:38:20 UTC
Thank you for the quick response.
Update to python2-paramiko 1.16.1-2.el7 fixed the issue.


Note You need to log in before you can comment on or make changes to this bug.