Bug 142073 - gnome-vfs2-2.8.2-8.src.rpm won't build with samba-3.0.8-1.4E.1 installed
gnome-vfs2-2.8.2-8.src.rpm won't build with samba-3.0.8-1.4E.1 installed
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: gnome-vfs2 (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-06 22:08 EST by Johnny Hughes
Modified: 2013-04-02 00:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-07 05:39:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Johnny Hughes 2004-12-06 22:08:16 EST
Description of problem:
gnome-vfs2-2.8.2-8.src.rpm won't build on RHEL4B2 with
samba-3.0.8-1.4E.1 installed (it builds fine with samba-3.0.8-0.pre1.3
installed)

The error is:

Processing files: gnome-vfs2-2.8.2-8
error: File not found:
/var/tmp/gnome-vfs2-2.8.2-root/etc/gnome-vfs-2.0/modules/smb-module.conf
error: File not found:
/var/tmp/gnome-vfs2-2.8.2-root/usr/lib/gnome-vfs-2.0/modules/libsmb.so
Executing(%doc): /bin/sh -e /var/tmp/rpm-tmp.41152
+ umask 022
+ cd /home/buildsys/rpmbuild/BUILD
+ cd gnome-vfs-2.8.2
+ DOCDIR=/var/tmp/gnome-vfs2-2.8.2-root/usr/share/doc/gnome-vfs2-2.8.2
+ export DOCDIR
+ rm -rf /var/tmp/gnome-vfs2-2.8.2-root/usr/share/doc/gnome-vfs2-2.8.2
+ /bin/mkdir -p
/var/tmp/gnome-vfs2-2.8.2-root/usr/share/doc/gnome-vfs2-2.8.2
+ cp -pr AUTHORS COPYING ChangeLog NEWS README
/var/tmp/gnome-vfs2-2.8.2-root/usr/share/doc/gnome-vfs2-2.8.2
+ exit 0
Processing files: gnome-vfs2-devel-2.8.2-8
Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
Requires: GConf2-devel >= 1.2.0 gnome-vfs2 = 2.8.2 libbonobo-devel >=
2.2.0
Conflicts: bonobo-devel < 1.0.8 gnome-vfs-devel < 1.0.2
Processing files: gnome-vfs2-smb-2.8.2-8
error: File not found:
/var/tmp/gnome-vfs2-2.8.2-root/usr/lib/gnome-vfs-2.0/modules/libsmb.so
error: File not found:
/var/tmp/gnome-vfs2-2.8.2-root/etc/gnome-vfs-2.0/modules/smb-module.conf


RPM build errors:
    File not found:
/var/tmp/gnome-vfs2-2.8.2-root/etc/gnome-vfs-2.0/modules/smb-module.conf
    File not found:
/var/tmp/gnome-vfs2-2.8.2-root/usr/lib/gnome-vfs-2.0/modules/libsmb.so
    File not found:
/var/tmp/gnome-vfs2-2.8.2-root/usr/lib/gnome-vfs-2.0/modules/libsmb.so
    File not found:
/var/tmp/gnome-vfs2-2.8.2-root/etc/gnome-vfs-2.0/modules/smb-module.conf


Version-Release number of selected component (if applicable):
gnome-vfs2-2.8.2-8

How reproducible:
Always

Steps to Reproduce:
rpmbuild --rebuild gnome-vfs2-2.8.2-8.src.rpm

(after installing samba-3.0.8-1.4E.1)
    

Additional info:
Comment 1 Jay Turner 2004-12-07 05:39:54 EST
gnome-vfs2-2.8.2-8 does indeed fail with samba-3.0.8-1.4E.1 installed, but
compiles just fine with samba-3.0.9-1.4E which is included in the latest tree.
gnome-vfs2-2.8.2-8.1 (also in the latest trees) compiles just fine with
3.0.9-1.4E as well.

Note You need to log in before you can comment on or make changes to this bug.