Bug 142081 - Results differ from "parted" and "sfdisk".
Results differ from "parted" and "sfdisk".
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: parted (Show other bugs)
4.0
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-07 01:15 EST by L3support
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-27 10:39:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description L3support 2004-12-07 01:15:26 EST
Description of problem:

When we run "parted",
the results differ from "sfdisk".

Version-Release number of selected component (if applicable):
parted-1.6.12-2
util-linux-2.12a-6

How reproducible:
Always

Steps to Reproduce:
1.# parted /dev/sda
2.(parted) p
3.check partition table
4.# sfdisk -l /dev/sda  
5.check partition table  

<Result> ----------------------------------------------
=== [parted] ====
/dev/sdaの Disk geometry: 0.000-140014.398 メガバイト
ディスクラベルの種類: gpt
マイナー 開始        終了    ファイルシステム 名前                  フラグ
1          0.017    256.016  fat16                             boot
2        256.017  40256.016  ext3
3      40256.017  60256.016  ext3
4      60256.017  80256.016  ext3
5      80256.017  90256.016  ext3
6      90256.017  98256.016  linux-swap
7      98256.017 107256.016  ext3
8     107256.016 140014.382  ext3

=== [sfdisk] ====
Disk /dev/sda: 17849 cylinders, 255 heads, 63 sectors/track
Units = cylinders of 8225280 bytes, blocks of 1024 bytes, counting from 0

   Device Boot Start     End   #cyls    #blocks   Id  System
/dev/sda1          0+  17849-  17850- 143374743+  ee  EFI GPT
                start: (c,h,s) expected (0,0,2) found (0,0,1)
/dev/sda2          0       -       0          0    0  Empty
/dev/sda3          0       -       0          0    0  Empty
/dev/sda4          0       -       0          0    0  Empty
------------------------------------------------------

Actual results:
Results differ from "parted" and "sfdisk".

Expected results:
 - "parted" can run properly.
 - "sfdisk" can run properly.

Additional info:
Comment 1 Jay Turner 2004-12-07 05:16:21 EST
sfdisk doesn't understand GPT partitions, so this explains the difference in
display.  parted does understand GPT partitioning, so it's able to unroll what
the action partitions look like and display data accordingly.
Comment 2 Andrew Clausen 2004-12-20 19:44:54 EST
Why was this reopened?  Jay is correct.
Comment 3 L3support 2004-12-27 03:40:44 EST
Sorry, we forgot additional comment.

We have question to your comment.

We think "sfdisk" is useless on RHEL4.
-------------------------------------------
sfdisk doesn't understand GPT partitions, so this explains the
difference in
display.
-------------------------------------------

If "sfdisk" is useless on RHEL4, 
could you remove "sfdisk" ?

Since user thinks "sfdisk" can use,
they think "sfdisk" can not run properly.
Comment 4 Jeremy Katz 2004-12-27 10:39:38 EST
MS-DOS partition tables are, although not common, perfectly legal to
have on ia64 at which point sfdisk can (in certain situations) be useful.

Note You need to log in before you can comment on or make changes to this bug.