Bug 1420853 - Openvswitch package not build with dpdk
Summary: Openvswitch package not build with dpdk
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: RDO
Classification: Community
Component: openstack-tripleo
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: trunk
Assignee: James Slagle
QA Contact: Shai Revivo
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-09 16:01 UTC by Sanjay Upadhyay
Modified: 2017-09-22 10:24 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-22 10:24:41 UTC


Attachments (Terms of Use)
search for openvswitch on all the repos of stock centos image (14.21 KB, text/plain)
2017-09-14 09:00 UTC, Sanjay Upadhyay
no flags Details

Description Sanjay Upadhyay 2017-02-09 16:01:05 UTC
Description of problem:

Unable to deploy tripleo with ovs-dpdk scenario, which was released with newton release. The issue is that openvswitch package is not built with dpdk binaries, hence dpdk options cannot be applied.


Version-Release number of selected component (if applicable):
[heat-admin@overcloud-novacompute-0 ~]$ sudo ovs-vswitchd --version
ovs-vswitchd (Open vSwitch) 2.5.0
Compiled Mar 18 2016 15:00:13
[heat-admin@overcloud-novacompute-0 ~]$ rpm -q openvswitch
openvswitch-2.5.0-2.el7.x86_64


How reproducible:
always

Steps to Reproduce:
1.Deploy tripleo on centos 7.3 with ovs-dpdk parameters ( https://access.redhat.com/documentation/en/red-hat-openstack-platform/10/paged/network-functions-virtualization-configuration-guide/chapter-3-configure-dpdk-accelerated-open-vswitch-ovs-for-networking ) 
2. Once deployed run ovs-vsctl show (check the dpdk port)
3.

Actual results:
[heat-admin@overcloud-novacompute-0 ~]$ sudo  ovs-vsctl get Open_vSwitch . iface_types
[geneve, gre, internal, ipsec_gre, lisp, patch, stt, system, tap, vxlan]


Expected results:
[heat-admin@overcloud-novacompute-0 ~]$ sudo  ovs-vsctl get Open_vSwitch . iface_types
[dpdk, geneve, gre, internal, ipsec_gre, lisp, patch, stt, system, tap, vxlan]


Additional info:

Comment 1 Christopher Brown 2017-06-29 11:47:14 UTC
Hi Sanjay,

These are the docs you need to use primarily for an RDO deployment.

http://tripleo.org/advanced_deployment/ovs_dpdk_config.html

There is a specific package that provides dpdk support so I'm closing this NOTABUG, please re-open if not the case.

Cheers

Comment 2 Sanjay Upadhyay 2017-09-14 08:55:25 UTC
Hi Christopher,

the above docs are ok, but where are the packages for openvswitch?
I tried searching on the latest centos image, and going through all the repositories which come on stock centos, and could not find  openvswitch package.

Comment 3 Sanjay Upadhyay 2017-09-14 09:00:06 UTC
Created attachment 1325845 [details]
search for openvswitch on all the repos of stock centos image

Here is a run on all the enabled and disabled repos which comes in a stock centos image. I couldnt find openvswitch packages. In which case how would this document ever work? http://tripleo.org/advanced_deployment/ovs_dpdk_config.html

Comment 4 Christopher Brown 2017-09-14 09:19:29 UTC
(In reply to Sanjay Upadhyay from comment #3)
> Created attachment 1325845 [details]
> search for openvswitch on all the repos of stock centos image
> 
> Here is a run on all the enabled and disabled repos which comes in a stock
> centos image. I couldnt find openvswitch packages. In which case how would
> this document ever work?
> http://tripleo.org/advanced_deployment/ovs_dpdk_config.html

It wont work because you don't have the correct repos enabled.

You need to read the full guide, especially the section on enabling the correct repositories.

http://tripleo.org/install/installation/installation.html#installing-the-undercloud

Comment 5 Sanjay Upadhyay 2017-09-15 12:23:08 UTC
Hi Christopher,

Sorry, but re-opening again. 

I have undercloud centos-7.4. The openvswitch package 

Here is the run -
[stack@undercloud ~]$ date
Fri Sep 15 12:18:51 UTC 2017
[stack@undercloud ~]$ yum list openvswitch -q
Installed Packages
openvswitch.x86_64                                                                 1:2.7.2-3.1fc27.el7                                                                  @delorean-pike-testing
[stack@undercloud ~]$ cat /etc/redhat-release 
CentOS Linux release 7.4.1708 (Core) 
[stack@undercloud ~]$ sudo  ovs-vsctl get Open_vSwitch . iface_types
[geneve, gre, internal, lisp, patch, stt, system, tap, vxlan]



Please note
For DPDK to work we need iface_types
[dpdk, geneve, gre, internal, ipsec_gre, lisp, patch, stt, system, tap, vxlan]


Hence, the doc here would not work for centos at least - http://tripleo.org/advanced_deployment/ovs_dpdk_config.html

Comment 6 Sanjay Upadhyay 2017-09-22 10:24:41 UTC
Checked with dpdk-init=true

ovs-vsctl set Open_vSwitch . other_config:dpdk-init=true

Now, its showing the iface types as dpdk

[root@ho302 ~]# ovs-vsctl get Open_vSwitch . iface_types
[dpdk, dpdkr, dpdkvhostuser, dpdkvhostuserclient, geneve, gre, internal, lisp, patch, stt, system, tap, vxlan]


Note You need to log in before you can comment on or make changes to this bug.