Bug 1421018 - [RFE] Provide a way to easily scale the cluster with SSL setup
Summary: [RFE] Provide a way to easily scale the cluster with SSL setup
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: gdeploy
Version: rhgs-3.2
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: ---
Assignee: Sachidananda Urs
QA Contact: SATHEESARAN
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-10 06:21 UTC by SATHEESARAN
Modified: 2018-10-22 07:13 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-22 07:13:53 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description SATHEESARAN 2017-02-10 06:21:47 UTC
Description of problem:
------------------------
With the current Gdeploy  ( 2.0.1-9 ), user could setup the SSL.
But when scaling, setting up SSL with the additional host is a pain.

Provide a way to setup SSL on a newly added hosts using self-signed cert mechanism

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
gdeploy-2.0.1-9.el7rhgs

How reproducible:
-----------------
Not Applicable

Steps to Reproduce:
-------------------
Not Applicable

Actual results:
---------------
Unable to setup SSL using gdeploy with the additional host ( which is added to cluster post SSL setup on that cluster )

Expected results:
-----------------
Provide a way to setup SSL using gdeploy with the additional host

Additional info:
----------------
With the self-signed cert mechanism, glusterfs.ca file is the concatenation of glusterfs.pem file on each node in the cluster. So when generating the new glusterfs.pem files on the newly added node to the cluster, gdeploy should make sure to get the glusterfs.ca file from any of the host already existing in the cluster, and append the newly generated glusterfs.pem to it and distribute it again to all the nodes in the cluster.

Comment 3 Sachidananda Urs 2018-10-22 05:38:16 UTC
Since this functionality will be moved to gluster-ansible in future, this bug is flagged for closure. If there is a requirement to fix in 3.x please update the bug.


Note You need to log in before you can comment on or make changes to this bug.