Bug 1421221 - AWS Storage in eu-west-2
Summary: AWS Storage in eu-west-2
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Containers
Version: 3.4.1
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Michal Fojtik
QA Contact: DeShuai Ma
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-10 16:02 UTC by Ruben Romero Montes
Modified: 2020-04-15 15:16 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-24 19:38:20 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Ruben Romero Montes 2017-02-10 16:02:33 UTC
Description of problem:
Even though this bugzilla has been resolved for Openshift in https://bugzilla.redhat.com/show_bug.cgi?id=1400746
The Docker version included is not yet supporting it, see https://github.com/docker/distribution/pull/2140/files

After upgrading to 3.4.1.2 and deploying the docker-registry on that region the following error is shown:
BucketRegionError: incorrect region, the bucket is not in 'eu-west-2'

Version-Release number of selected component (if applicable):
image: openshift3/ose-docker-registry:v3.4.1.2
oc v3.4.1.2
kubernetes v1.4.0+776c994
Docker 1.12.5

How reproducible:
Always

Steps to Reproduce:
1.Deploy the registry
AWS_PROFILE=iukorg S3_ACCESS_KEY_ID=xxxxxxxxxxxx S3_SECRET_ACCESS_KEY="xxxxxxxxxxx" ansible-playbook -lcpm1, -e "clusterid=openshift-prod" -e "aws_bucket=iukprod-openshift-registry" -e "aws_region=eu-west-2" -e "aws_tmp_path=/tmp" /usr/share/ansible/openshift-ansible/playbooks/adhoc/s3_registry/s3_registry.yml

2. I've checked and can confirm the bucket it is the eu-west-2 region:

[ec2-user@ip-10-0-0-163 ~]$ AWS_REGION=eu-west-2 AWS_PROFILE=iukorg aws s3 ls | grep iukprod-openshift-registry
2017-02-09 09:45:47 iukprod-openshift-registry

Actual results:
BucketRegionError: incorrect region, the bucket is not in 'eu-west-2'

Expected results:
The registry deployed on region eu-west-2

Additional info:

Comment 1 Antonio Murdaca 2017-02-10 18:04:19 UTC
This seems to be an issue with docker-registry rather than docker itself. Not sure what to do with the PR linked in the first comment.

Michal, since you did that PR, could you take a look at this?


Note You need to log in before you can comment on or make changes to this bug.