Bug 1421239 - OCP deployment hands DNS name rather than IP to "oc create" which causes a failure.
Summary: OCP deployment hands DNS name rather than IP to "oc create" which causes a fa...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: doc-Installation_Guide
Version: 1.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 1.1
Assignee: Julie
QA Contact: James Olin Oden
URL:
Whiteboard:
Depends On: 1420929
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-10 17:10 UTC by John Matthews
Modified: 2017-02-28 01:46 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1420929
Environment:
Last Closed: 2017-02-28 01:46:08 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:0335 0 normal SHIPPED_LIVE Red Hat Quickstart Installer 1.1 2017-02-28 06:36:13 UTC

Description John Matthews 2017-02-10 17:10:52 UTC
+++ This bug was initially created as a clone of Bug #1420929 +++

Description of problem:
When you do an OCP deployment with gluster for storage, you will get the following error in the ansible.log on the fusor server if you specified
a FQDN for the address of the gluster server:

7-02-09 16:29:28,029 p=14510 u=foreman | fatal: [rootofweevils-ocp-master1.b.b]: FAILED! => {"changed": true, "cmd": ["oc", "create", "-f", "/home/cloudsuite-install/pod_examples/glusterfs-endpoints.yaml"], "delta": "0:00:00.246671", "end": "2017-02-09 16:29:25.767250", "failed": true, "rc": 1, "start": "2017-02-09 16:29:25.520579", "stderr": "The Endpoints \"glusterfs-cluster\" is invalid.\nsubsets[0].addresses[0].ip: Invalid value: \"gluster.b.b\": must be a valid IP address", "stdout": "", "stdout_lines": [], "warnings": []}

On a hunch from Landon I checked to see if you ran the command with the IP address in the yaml file rather than with FQDN, if it would succeed and it did.

I personally think this is a bug in the "oc create" command because it should be able to handle a resolvable DNS address, however short term it may be better to just make sure the YAML file gets the IP address rather than the DNS address.

The failure is at 90%

Version-Release number of selected component (if applicable):
QCI-1.1-RHEL-7-20170208.t.0

How reproducible:
Every time

Steps to Reproduce:
1.  Do an OCP deployment with gluster and specify the FQDN for the address
    of the gluster server.

Actual results:
It fails at 90% with the above error.

Expected results:
No failure.

--- Additional comment from John Matthews on 2017-02-10 12:10:03 EST ---

According to below link OCP requires IP's and not hostnames with gluster.

https://docs.openshift.org/latest/install_config/persistent_storage/persistent_storage_glusterfs.html#creating-gluster-endpoints

"The ip values must be the actual IP addresses of a Gluster server, not fully-qualified host names"

Comment 1 John Matthews 2017-02-10 17:11:57 UTC
We need to ensure the install guide calls out that for Gluster with OCP an IP should be used and not a hostname.

Comment 4 James Olin Oden 2017-02-13 14:27:48 UTC
Verified in version 1.1 of the docs.

Comment 6 errata-xmlrpc 2017-02-28 01:46:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:0335


Note You need to log in before you can comment on or make changes to this bug.