Bug 1421268 - SELinux is preventing 57656220436F6E74656E74 from 'create' accesses on the file Kvitto-Dell-UP2516D.pdf.
Summary: SELinux is preventing 57656220436F6E74656E74 from 'create' accesses on the fi...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 25
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:b8dacb63c304326016645efad41...
: 1444238 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-10 19:18 UTC by Robin
Modified: 2017-04-25 18:03 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-24 19:46:04 UTC
Type: ---


Attachments (Terms of Use)

Description Robin 2017-02-10 19:18:36 UTC
Description of problem:
This happened when trying to "Print to file". This should definitely be allowed as it's used when printing recipts to disk.
This happend when using the "Print to file" functionality of Firefox.

SELinux is preventing 57656220436F6E74656E74 from 'create' accesses on the file Kvitto-Dell-UP2516D.pdf.

*****  Plugin mozplugger (99.1 confidence) suggests   ************************

If you want to use the plugin package
Then you must turn off SELinux controls on the Firefox plugins.
Do
# setsebool -P unconfined_mozilla_plugin_transition 0

*****  Plugin catchall (1.81 confidence) suggests   **************************

If you believe that 57656220436F6E74656E74 should be allowed create access on the Kvitto-Dell-UP2516D.pdf file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c '57656220436F6E74656E74' --raw | audit2allow -M my-57656220436F6E74656E74
# semodule -X 300 -i my-57656220436F6E74656E74.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
                              0.c1023
Target Context                unconfined_u:object_r:user_home_dir_t:s0
Target Objects                Kvitto-Dell-UP2516D.pdf [ file ]
Source                        57656220436F6E74656E74
Source Path                   57656220436F6E74656E74
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-225.6.fc25.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.9.7-201.fc25.x86_64 #1 SMP Thu
                              Feb 2 23:32:42 UTC 2017 x86_64 x86_64
Alert Count                   1
First Seen                    2017-02-10 20:15:05 CET
Last Seen                     2017-02-10 20:15:05 CET
Local ID                      19bb9697-e3d4-4960-ad38-80501eaad162

Raw Audit Messages
type=AVC msg=audit(1486754105.47:235): avc:  denied  { create } for  pid=3270 comm=57656220436F6E74656E74 name="Kvitto-Dell-UP2516D.pdf" scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_dir_t:s0 tclass=file permissive=0


Hash: 57656220436F6E74656E74,mozilla_plugin_t,user_home_dir_t,file,create

Version-Release number of selected component:
selinux-policy-3.13.1-225.6.fc25.noarch

Additional info:
reporter:       libreport-2.8.0
hashmarkername: setroubleshoot
kernel:         4.9.7-201.fc25.x86_64
type:           libreport

Comment 1 Manu 2017-04-10 03:46:38 UTC
Description of problem:
Este error me aparecio mientras intentaba imprimir un archivo que estaba bajando desde una pagina web.

Version-Release number of selected component:
selinux-policy-3.13.1-225.11.fc25.noarch

Additional info:
reporter:       libreport-2.8.0
hashmarkername: setroubleshoot
kernel:         4.10.8-200.fc25.x86_64
type:           libreport

Comment 2 Giulio 'juliuxpigface' 2017-04-22 07:29:25 UTC
Description of problem:
I tried to print a PDF from firefox.

Version-Release number of selected component:
selinux-policy-3.13.1-225.11.fc25.noarch

Additional info:
reporter:       libreport-2.8.0
hashmarkername: setroubleshoot
kernel:         4.10.9-200.fc25.x86_64
type:           libreport

Comment 3 Giulio 'juliuxpigface' 2017-04-24 19:46:04 UTC
Looks like it has been solved with the update "firefox-53.0-2.fc25.x86_64". Feel free to reopen this if you encounter hit this issue again.

Comment 4 Giulio 'juliuxpigface' 2017-04-24 19:55:29 UTC
*** Bug 1444238 has been marked as a duplicate of this bug. ***

Comment 5 John Guynn 2017-04-25 18:03:48 UTC
Description of problem:
Attempting to print to a File using Firefox creates this issue.

Version-Release number of selected component:
selinux-policy-3.13.1-225.11.fc25.noarch

Additional info:
reporter:       libreport-2.8.0
hashmarkername: setroubleshoot
kernel:         4.10.10-200.fc25.x86_64
type:           libreport


Note You need to log in before you can comment on or make changes to this bug.