Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 142129 - generate-rss command gives IndexError
generate-rss command gives IndexError
Status: CLOSED DUPLICATE of bug 138376
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-07 11:03 EST by Joseph Wilhelm
Modified: 2014-01-21 17:50 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joseph Wilhelm 2004-12-07 11:03:58 EST
This is on a Fedora Core 3 installation; this package is fully
updated, version 2.1.11-3

Running the following command:
yum --rss-filename=foo.rss generate-rss

I get this error:
Traceback (most recent call last):
  File "/usr/bin/yum", line 8, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 51, in main
    base.getOptionsConfig(args)
  File "/usr/share/yum-cli/cli.py", line 245, in getOptionsConfig
    self.parseCommands() # before we exit check over the base command
+ args
  File "/usr/share/yum-cli/cli.py", line 340, in parseCommands
    self.extcmds[0] = 'recent'
IndexError: list assignment index out of range

It's easy enough to fix.. all I did was change line 340 to:
self.extcmds.append( 'recent' )

And now it works like a dream :)
Comment 1 Seth Vidal 2004-12-07 11:06:46 EST
duplicate of 138376 and it's been fixed upstream but yum 2.1.12 has
not been released to fedore core 3 people yet <glare>

*** This bug has been marked as a duplicate of 138376 ***
Comment 2 Joseph Wilhelm 2004-12-07 11:27:39 EST
My apologies, I guess I should start searching the contents of the
bugs instead of just summaries.. it just happens there isn't a single
yum bug with "IndexError" or "index out of range" in the summary :)
Comment 3 Red Hat Bugzilla 2006-02-21 14:07:35 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.