Bug 142206 - ~/.gnupg does not appear to be created
Summary: ~/.gnupg does not appear to be created
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: gnupg   
(Show other bugs)
Version: 4.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Nalin Dahyabhai
QA Contact: Mike McLean
URL:
Whiteboard: RHEL4U3NAK
Keywords:
: 150935 191685 (view as bug list)
Depends On:
Blocks: 187538
TreeView+ depends on / blocked
 
Reported: 2004-12-08 03:31 UTC by Brad Smith
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version: RHBA-2006-0416
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-10 22:00:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2006:0416 normal SHIPPED_LIVE gnupg enhancement update 2006-05-10 04:00:00 UTC

Description Brad Smith 2004-12-08 03:31:09 UTC
Description of problem:
Gnupg does not appear to create the ~/.gnupg directory and then dies
when trying to create a new key.

Version-Release number of selected component (if applicable): 1.2.6


How reproducible: Always


Steps to Reproduce:
1. gpg --gen-key
2. use all defaults (probably doesn't matter)
  
Actual results:
key generation will fail when gpg attempts to store the generated key
in ~/.gnupg

Expected results:
~/.gnupg created if it doesn't already exist

Additional info:
Works fine after manually creating ~/.gnupg

Comment 1 Nalin Dahyabhai 2005-09-07 18:20:12 UTC
*** Bug 150935 has been marked as a duplicate of this bug. ***

Comment 8 Radek Bíba 2006-03-14 22:13:19 UTC
Oh, actually not. The fix has been finally reverted from the errata packages.

Comment 15 Red Hat Bugzilla 2006-05-10 22:00:52 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0416.html


Comment 16 Nalin Dahyabhai 2006-05-15 09:28:08 UTC
*** Bug 191685 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.