Bug 142221 - xorg still crashes on fc3
xorg still crashes on fc3
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-08 03:05 EST by Bjorn Karlsen
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-15 10:38:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (53.43 KB, text/plain)
2004-12-08 03:14 EST, Bjorn Karlsen
no flags Details
xorg.conf (2.79 KB, text/plain)
2004-12-08 03:15 EST, Bjorn Karlsen
no flags Details
/var/log/messages (1.26 KB, text/plain)
2004-12-13 04:21 EST, Bjorn Karlsen
no flags Details
Xorg.0.log (50.28 KB, text/plain)
2004-12-21 03:16 EST, Bjorn Karlsen
no flags Details
excerpt from /var/log/messages (4.23 KB, text/plain)
2004-12-21 03:21 EST, Bjorn Karlsen
no flags Details
Output of 'ps -ef' after the crash (3.75 KB, text/plain)
2004-12-21 03:23 EST, Bjorn Karlsen
no flags Details
xorg.conf (2.81 KB, text/plain)
2004-12-21 03:24 EST, Bjorn Karlsen
no flags Details

  None (edit)
Description Bjorn Karlsen 2004-12-08 03:05:40 EST
I have upgraded to xorg-x11-6.8.1-12.FC3.21 as suggested in bug 139260.
My system still crashes at random intervals (could be days between crashes). Seems 
like the crashes occur when I'm using kmail, but this could be accidental.

[root@feathers X11]# uname -a
Linux feathers 2.6.9-1.681_FC3 #1 Thu Nov 18 15:10:10 EST 2004 i686 i686 i386 GNU/
Linux
[root@feathers X11]# rpm -q xorg-x11
xorg-x11-6.8.1-12.FC3.21

This happens on a system with Intel 845.
Comment 1 Bjorn Karlsen 2004-12-08 03:14:01 EST
Created attachment 108094 [details]
Xorg.0.log
Comment 2 Bjorn Karlsen 2004-12-08 03:15:01 EST
Created attachment 108095 [details]
xorg.conf
Comment 3 Kristian Høgsberg 2004-12-12 11:53:34 EST
Your problem looks like a duplicate of bug 142240.  Is your bug
triggered by login/logout or shutdown?  What kind of crash do you see?
 Hard lockup, spontaneous reboot?  Can you ssh into the machine when
it's crashed?  Could you attach /var/log/message after a crash? Thanks.
Comment 4 Bjorn Karlsen 2004-12-13 04:18:19 EST
> Is your bug triggered by login/logout or shutdown?

No. I've been logged in for hours or even days when it occured.
However, as far as I remember, I was using KMail every time it 
happened.
At one occasion I know for sure that I was marking text in a mail 
composing window, using the keyboard.
Kmail 1.7.1 (Using KDE 3.3.1-2.2 Red Hat)

I don't use graphical login.

>  What kind of crash do you see? Hard lockup, spontaneous reboot?

Screen lockup. The bottom 2-3 cm of the screen gets garbled (like 
attachment 104038 [details] of Bug # 133010). Other parts of the screen looks 
like it did before the lockup.
I was not able to use the keyboard nor the mouse.

> Can you ssh into the machine when it's crashed?

Yes.

> Could you attach /var/log/message after a crash?

I looked into /var/log/messages when the last crash occured, but 
didn't find anything useful. I have attached a part of the messages 
file from around the time when the lockup happened.

I have added Option "NoAccel" to /etc/X11/xorg.conf since the last 
lockup, and so far it seems like the problem has disappeared.

HW: Compaq Evo D510 CMT
Comment 5 Bjorn Karlsen 2004-12-13 04:21:19 EST
Created attachment 108425 [details]
/var/log/messages
Comment 6 Bjorn Karlsen 2004-12-21 03:14:15 EST
It happened again. This time it happened at 02:28 in the morning 
(according to the timestamp of Xorg.0.log). I was not using the PC at 
the time.
Screen Saver (Slide Show) was running, and the PC hung during 
transition bewteen 2 images.
I know for sure that kmail was NOT running.
I was able to ssh into the machine.
Comment 7 Bjorn Karlsen 2004-12-21 03:16:41 EST
Created attachment 108929 [details]
Xorg.0.log
Comment 8 Bjorn Karlsen 2004-12-21 03:21:20 EST
Created attachment 108930 [details]
excerpt from /var/log/messages
Comment 9 Bjorn Karlsen 2004-12-21 03:23:19 EST
Created attachment 108931 [details]
Output of 'ps -ef' after the crash
Comment 10 Bjorn Karlsen 2004-12-21 03:24:44 EST
Created attachment 108932 [details]
xorg.conf
Comment 11 Mike A. Harris 2005-01-31 23:15:57 EST
Please upgrade to the xorg-x11-6.8.1.903 (or newer) rpm packages in
Fedora development (rawhide), which contain numerous bug fixes
since the 6.8.1 release.  This will be finalized as 6.8.2 very
soon and released as an update for Fedora Core 3.

If the problem still exists in the new version of xorg-x11 in
rawhide, please file a bug report in X.Org bugzilla located at
http://bugs.freedesktop.org in the "xorg" component, detailing
the problem with specific steps to reproduce, and attaching
the config/log files to the X.Org report as you've done above.

Once you've filed your report in the X.Org bugzilla, if you paste
the URL here, Red Hat will track the issue in X.org bugzilla and
will review any fixes that become available for consideration in
future Fedora Core updates.

Thanks in advance.
Comment 12 Mike A. Harris 2005-01-31 23:18:04 EST
Setting status to "NEEDINFO" awaiting upstream bug report URL, and
test results of using xorg-x11 from rawhide.
Comment 13 Mike A. Harris 2005-04-15 10:38:56 EDT
Assuming the problem is resolved in our latest erratum of 6.8.2 for FC3
and closing bug as "ERRATA" due to lack of feedback.

Note You need to log in before you can comment on or make changes to this bug.