Bug 142240 - kernel-2.6.9-1.698_FC3 Oops in X while shutdown from gdm
kernel-2.6.9-1.698_FC3 Oops in X while shutdown from gdm
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
Brian Brock
:
Depends On:
Blocks: 140583
  Show dependency treegraph
 
Reported: 2004-12-08 09:40 EST by Davide Rossetti
Modified: 2007-11-30 17:10 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-19 11:23:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspic -vvx (9.91 KB, text/plain)
2004-12-13 09:23 EST, Davide Rossetti
no flags Details
X11 log with kernel 2.6.9-1.681_FC3 (56.26 KB, text/plain)
2004-12-13 09:25 EST, Davide Rossetti
no flags Details
content /var/log/messages (19.42 KB, application/octet-stream)
2004-12-13 09:39 EST, Davide Rossetti
no flags Details
cat /proc/cpuinfo (397 bytes, text/plain)
2004-12-13 09:42 EST, Davide Rossetti
no flags Details

  None (edit)
Description Davide Rossetti 2004-12-08 09:40:54 EST
Description of problem:

after choosing shutdown in the gdm screen laptop locks.
the kernel was tainted by the unsuccessful insertion of slamr driver
which I reported in another bugzilla entry.
after reboot log/messages inspection reveals some Oops

Dec  8 02:02:19 localhost kernel: slamr: module license 'Smart Link
Ltd.' taints kernel.
Dec  8 02:02:19 localhost kernel: slamr: Unknown symbol get_device
Dec  8 02:02:19 localhost kernel: slamr: Unknown symbol put_device
Dec  8 02:02:19 localhost kernel: slamr: Unknown symbol
device_release_driver
...
Dec  8 02:11:59 localhost gdm(pam_unix)[3846]: session closed for user
drossetti
Dec  8 02:12:00 localhost kernel: mtrr: base(0xf0000000) is not
aligned on a size(0x180000) boundary
Dec  8 02:12:00 localhost kernel: Unable to handle kernel paging
request at virtual address ffffffb4
Dec  8 02:12:00 localhost kernel:  printing eip:
Dec  8 02:12:00 localhost kernel: c0182185
Dec  8 02:12:00 localhost kernel: *pde = 00002067
Dec  8 02:12:00 localhost kernel: Oops: 0000 [#1]
Dec  8 02:12:00 localhost kernel: Modules linked in: i915 md5 ipv6
parport_pc lp parport autofs4 i2c_dev i2c_c
ore ds sunrpc microcode dm_mod button battery asus_acpi ac ohci1394
ieee1394 yenta_socket pcmcia_core uhci_hcd
 snd_intel8x0 snd_ac97_codec snd_pcm_oss snd_mixer_oss snd_pcm
snd_timer snd_page_alloc gameport snd_mpu401_ua
rt snd_rawmidi snd_seq_device snd soundcore 8139too mii ext3 jbd
Dec  8 02:12:00 localhost kernel: CPU:    0
Dec  8 02:12:00 localhost kernel: EIP:    0060:[<c0182185>]   
Tainted: P      VLI
Dec  8 02:12:00 localhost kernel: EFLAGS: 00213206   (2.6.9-1.698_FC3)
Dec  8 02:12:00 localhost kernel: EIP is at __d_find_alias+0x35/0xa2
Dec  8 02:12:00 localhost kernel: eax: 0000a000   ebx: 00000000   ecx:
00000001   edx: d713e9d0
Dec  8 02:12:00 localhost kernel: esi: 00000000   edi: ffffffb0   ebp:
d713e9c0   esp: c7683e5c
Dec  8 02:12:00 localhost kernel: ds: 007b   es: 007b   ss: 0068
Dec  8 02:12:00 localhost kernel: Process X (pid: 16767,
threadinfo=c7683000 task=cffa2130)
Dec  8 02:12:00 localhost kernel: Stack: 00000001 d713e9c0 c7e1daa0
00000000 d70eed00 c0183c1d d713e9c0 c7e1daa0
Dec  8 02:12:00 localhost kernel:        d750a000 d8108a7d d713f0bc
d811d2c0 c7e1daa0 d713ec74 c017733f c7683f30
Dec  8 02:12:00 localhost kernel:        c7683ef8 00000000 c7683f30
00000000 c7683ef8 c01776ba c1375aa0 c7683ef0
Dec  8 02:12:00 localhost kernel: Call Trace:
Dec  8 02:12:00 localhost kernel:  [<c0183c1d>] d_splice_alias+0xae/0x214
Dec  8 02:12:00 localhost kernel:  [<d8108a7d>] ext3_lookup+0x6e/0x87
[ext3]
Dec  8 02:12:00 localhost kernel:  [<c017733f>] real_lookup+0x73/0xde
Dec  8 02:12:00 localhost kernel:  [<c01776ba>] do_lookup+0x56/0x8f
Dec  8 02:12:00 localhost kernel:  [<c017839d>]
link_path_walk+0xcaa/0x1009
Dec  8 02:12:00 localhost kernel:  [<c015683f>]
handle_mm_fault+0x131/0x233
Dec  8 02:12:00 localhost kernel:  [<c0178977>] path_lookup+0xff/0x12f
Dec  8 02:12:00 localhost kernel:  [<c0173b7f>] open_exec+0x1a/0xa5
Dec  8 02:12:00 localhost kernel:  [<c011a4dc>] do_page_fault+0x0/0x4dc
Dec  8 02:12:00 localhost kernel:  [<c017550a>] do_execve+0x16/0x1f6
Dec  8 02:12:00 localhost kernel:  [<c0104964>] sys_execve+0x2a/0x6f
Dec  8 02:12:00 localhost kernel:  [<c031258b>] syscall_call+0x7/0xb
Dec  8 02:12:00 localhost kernel: Code: 14 24 8b 48 10 8d 50 10 39 d1
0f 84 80 00 00 00 89 cb 8b 09 0f 18 01 90 0f b7 45 20 8d 7b b0 25 00
f0 00 00 3d 00 40 00 00 74 06 <f6> 47 04 10 75 36 f6 47 04 04 74 04 89
fe eb 2c 83 3c 24 00 75
Dec  8 02:12:00 localhost kernel:  ------------[ cut here ]------------
Dec  8 02:12:00 localhost kernel: kernel BUG at mm/mmap.c:1936!
Dec  8 02:12:00 localhost kernel: invalid operand: 0000 [#2]
Dec  8 02:12:00 localhost kernel: Modules linked in: i915 md5 ipv6
parport_pc lp parport autofs4 i2c_dev i2c_c
ore ds sunrpc microcode dm_mod button battery asus_acpi ac ohci1394
ieee1394 yenta_socket pcmcia_core uhci_hcd
 snd_intel8x0 snd_ac97_codec snd_pcm_oss snd_mixer_oss snd_pcm
snd_timer snd_page_alloc gameport snd_mpu401_ua
rt snd_rawmidi snd_seq_device snd soundcore 8139too mii ext3 jbd
Dec  8 02:12:00 localhost kernel: CPU:    0
Dec  8 02:12:00 localhost kernel: EIP:    0060:[<c015974a>]   
Tainted: P      VLI
Dec  8 02:12:00 localhost kernel: EFLAGS: 00213202   (2.6.9-1.698_FC3)
Dec  8 02:12:00 localhost kernel: EIP is at exit_mmap+0xe0/0x1e5
Dec  8 02:12:00 localhost kernel: eax: 00000000   ebx: cf835880   ecx:
cf441a50   edx: 00000000
Dec  8 02:12:00 localhost kernel: esi: cffa2130   edi: cf8358b0   ebp:
0000000b   esp: c7683ce4
Dec  8 02:12:00 localhost kernel: ds: 007b   es: 007b   ss: 0068
Dec  8 02:12:00 localhost kernel: Process X (pid: 16767,
threadinfo=c7683000 task=cffa2130)
Dec  8 02:12:00 localhost kernel: Stack: c03ea0b4 00000000 cf835880
cffa2130 c011e850 cf835880 c0124210 c7683000
Dec  8 02:12:00 localhost kernel:        00000000 c0321091 d713e9c0
c01068c1 0000000b c7683e28 c0321091 00000000
Dec  8 02:12:00 localhost kernel:        000000ff 0000000b c0321028
00000000 cffa2130 c0321028 00000000 cffa2130
Dec  8 02:12:00 localhost kernel: Call Trace:
Dec  8 02:12:00 localhost kernel:  [<c011e850>] mmput+0xb9/0xdc
Dec  8 02:12:00 localhost kernel:  [<c0124210>] do_exit+0x2be/0x767
Dec  8 02:12:00 localhost kernel:  [<c01068c1>] do_divide_error+0x0/0xea
Dec  8 02:12:00 localhost kernel:  [<c011a85c>] do_page_fault+0x380/0x4dc
Dec  8 02:12:00 localhost kernel:  [<c0182185>] __d_find_alias+0x35/0xa2
Dec  8 02:12:00 localhost kernel:  [<c0310cf2>] __cond_resched+0x14/0x3b
Dec  8 02:12:00 localhost kernel:  [<d81050c6>] ext3_getblk+0xb4/0x1fa
[ext3]
Dec  8 02:12:00 localhost kernel:  [<c0168caa>] wake_up_buffer+0x9/0x29
Dec  8 02:12:00 localhost kernel:  [<d810879b>]
ext3_find_entry+0x283/0x363 [ext3]
Dec  8 02:12:00 localhost kernel:  [<c011a4dc>] do_page_fault+0x0/0x4dc
Dec  8 02:12:00 localhost kernel:  [<c031270f>] error_code+0x2f/0x38
Dec  8 02:12:00 localhost kernel:  [<c0182185>] __d_find_alias+0x35/0xa2
Dec  8 02:12:00 localhost kernel:  [<c0183c1d>] d_splice_alias+0xae/0x214
Dec  8 02:12:00 localhost kernel:  [<d8108a7d>] ext3_lookup+0x6e/0x87
[ext3]
Dec  8 02:12:00 localhost kernel:  [<c017733f>] real_lookup+0x73/0xde
Dec  8 02:12:00 localhost kernel:  [<c01776ba>] do_lookup+0x56/0x8f
Dec  8 02:12:00 localhost kernel:  [<c017839d>]
link_path_walk+0xcaa/0x1009
Dec  8 02:12:00 localhost kernel:  [<c015683f>]
handle_mm_fault+0x131/0x233
Dec  8 02:12:00 localhost kernel:  [<c0178977>] path_lookup+0xff/0x12f
Dec  8 02:12:00 localhost kernel:  [<c0173b7f>] open_exec+0x1a/0xa5
Dec  8 02:12:00 localhost kernel:  [<c011a4dc>] do_page_fault+0x0/0x4dc
Dec  8 02:12:00 localhost kernel:  [<c017550a>] do_execve+0x16/0x1f6
Dec  8 02:12:00 localhost kernel:  [<c0104964>] sys_execve+0x2a/0x6f
Dec  8 02:12:00 localhost kernel:  [<c031258b>] syscall_call+0x7/0xb
Dec  8 02:12:00 localhost kernel: Code: 00 00 c7 05 c4 a0 3e c0 00 00
00 00 8b 0b e8 0d ac ff ff 29 43 2c 83 c4 10 8b 44 24 04 f7 d8 01 05
b8 5c 41 c0 83 7b 2c 00 74 08 <0f> 0b 90 07 54 39 32 c0 8b 04 24 31 d2
b9 00 03 00 00 e8 87 a2
Dec  8 02:12:00 localhost kernel:  <1>Unable to handle kernel paging
request at virtual address 09d8b3f8
Dec  8 02:12:00 localhost kernel:  printing eip:
Dec  8 02:12:00 localhost kernel: c018928f
Dec  8 02:12:00 localhost kernel: *pde = 00000000
Dec  8 02:12:00 localhost kernel: Oops: 0000 [#3]
Dec  8 02:12:00 localhost kernel: Modules linked in: i915 md5 ipv6
parport_pc lp parport autofs4 i2c_dev i2c_c
ore ds sunrpc microcode dm_mod button battery asus_acpi ac ohci1394
ieee1394 yenta_socket pcmcia_core uhci_hcd
 snd_intel8x0 snd_ac97_codec snd_pcm_oss snd_mixer_oss snd_pcm
snd_timer snd_page_alloc gameport snd_mpu401_ua
rt snd_rawmidi snd_seq_device snd soundcore 8139too mii ext3 jbd
Dec  8 02:12:00 localhost kernel: CPU:    0
Dec  8 02:12:00 localhost kernel: EIP:    0060:[<c018928f>]   
Tainted: P      VLI
Dec  8 02:12:00 localhost kernel: EFLAGS: 00213246   (2.6.9-1.698_FC3)
Dec  8 02:12:00 localhost kernel: EIP is at dnotify_flush+0xe/0x124
Dec  8 02:12:00 localhost kernel: eax: cf46f540   ebx: d12c1100   ecx:
d12c1100   edx: cf80e3c0
Dec  8 02:12:00 localhost kernel: esi: 09d8b3d8   edi: d12c1100   ebp:
cf80e3c0   esp: c7683b7c
Dec  8 02:12:00 localhost kernel: ds: 007b   es: 007b   ss: 0068
Dec  8 02:12:00 localhost kernel: Process X (pid: 16767,
threadinfo=c7683000 task=cffa2130)
Dec  8 02:12:00 localhost kernel: Stack: d12c1100 00000000 cf80e3c0
00000001 c0166d7e cf80e3c0 0000001f 00000008
Dec  8 02:12:00 localhost kernel:        c01231a5 cf80e3c0 cffa2130
c031bec3 0000000b c0124348 c7683000 00000000
Dec  8 02:12:00 localhost kernel:        c031bec3 0000000b c01068c1
0000000b c7683cb0 c031bec3 00000000 000000ff
Dec  8 02:12:00 localhost kernel: Call Trace:
Dec  8 02:12:00 localhost kernel:  [<c0166d7e>] filp_close+0x49/0x5f
Dec  8 02:12:00 localhost kernel:  [<c01231a5>] put_files_struct+0x56/0xbf
Dec  8 02:12:00 localhost kernel:  [<c0124348>] do_exit+0x3f6/0x767
Dec  8 02:12:00 localhost kernel:  [<c01068c1>] do_divide_error+0x0/0xea
Dec  8 02:12:00 localhost kernel:  [<c0106ba3>] do_invalid_op+0x0/0xd5
Dec  8 02:12:00 localhost kernel:  [<c0136d83>]
search_exception_tables+0x1f/0x21
Dec  8 02:12:00 localhost kernel:  [<c0106ba3>] do_invalid_op+0x0/0xd5
Dec  8 02:12:00 localhost kernel:  [<c0106c6f>] do_invalid_op+0xcc/0xd5
Dec  8 02:12:00 localhost kernel:  [<c015974a>] exit_mmap+0xe0/0x1e5
Dec  8 02:12:00 localhost kernel:  [<c011c303>] activate_task+0x53/0x5f
Dec  8 02:12:00 localhost kernel:  [<c012aa2c>] update_wall_time+0x8/0x30
Dec  8 02:12:00 localhost kernel:  [<c012aecb>] do_timer+0x49/0xb5
Dec  8 02:12:00 localhost kernel:  [<c031270f>] error_code+0x2f/0x38
Dec  8 02:12:00 localhost kernel:  [<c015974a>] exit_mmap+0xe0/0x1e5
Dec  8 02:12:00 localhost kernel:  [<c011e850>] mmput+0xb9/0xdc
Dec  8 02:12:00 localhost kernel:  [<c0124210>] do_exit+0x2be/0x767
Dec  8 02:12:00 localhost kernel:  [<c01068c1>] do_divide_error+0x0/0xea
Dec  8 02:12:00 localhost kernel:  [<c011a85c>] do_page_fault+0x380/0x4dc
Dec  8 02:12:00 localhost kernel:  [<c0182185>] __d_find_alias+0x35/0xa2
Dec  8 02:12:00 localhost kernel:  [<c0310cf2>] __cond_resched+0x14/0x3b
Dec  8 02:12:00 localhost kernel:  [<d81050c6>] ext3_getblk+0xb4/0x1fa
[ext3]
Dec  8 02:12:00 localhost kernel:  [<c0168caa>] wake_up_buffer+0x9/0x29
Dec  8 02:12:00 localhost kernel:  [<d810879b>]
ext3_find_entry+0x283/0x363 [ext3]
Dec  8 02:12:00 localhost kernel:  [<c011a4dc>] do_page_fault+0x0/0x4dc
Dec  8 02:12:00 localhost kernel:  [<c031270f>] error_code+0x2f/0x38
Dec  8 02:12:00 localhost kernel:  [<c0182185>] __d_find_alias+0x35/0xa2
Dec  8 02:12:00 localhost kernel:  [<c0183c1d>] d_splice_alias+0xae/0x214
Dec  8 02:12:00 localhost kernel:  [<d8108a7d>] ext3_lookup+0x6e/0x87
[ext3]
Dec  8 02:12:00 localhost kernel:  [<c017733f>] real_lookup+0x73/0xde
Dec  8 02:12:00 localhost kernel:  [<c01776ba>] do_lookup+0x56/0x8f
Dec  8 02:12:00 localhost kernel:  [<c017839d>]
link_path_walk+0xcaa/0x1009
Dec  8 02:12:00 localhost kernel:  [<c015683f>]
handle_mm_fault+0x131/0x233
Dec  8 02:12:00 localhost kernel:  [<c0178977>] path_lookup+0xff/0x12f
Dec  8 02:12:00 localhost kernel:  [<c0173b7f>] open_exec+0x1a/0xa5
Dec  8 02:12:00 localhost kernel:  [<c011a4dc>] do_page_fault+0x0/0x4dc
Dec  8 02:12:00 localhost kernel:  [<c017550a>] do_execve+0x16/0x1f6
Dec  8 02:12:00 localhost kernel:  [<c0104964>] sys_execve+0x2a/0x6f
Dec  8 02:12:00 localhost kernel:  [<c031258b>] syscall_call+0x7/0xb
Dec  8 02:12:00 localhost kernel: Code: 00 89 c3 85 d2 74 0e 8b 42 04
8b 12 25 ff ff ff 7f 09 c1 eb ee 89 8b 9
4 01 00 00 5b c3 55 89 d5 57 89 c7 56 53 8b 40 08 8b 70 20 <0f> b7 46
20 25 00 f0 00 00 3d 00 40 00 00 0f 85 f
d 00 00 00 81
Dec  8 02:12:00 localhost kernel:  lib/dec_and_lock.c:32:
spin_lock(fs/dcache.c:c0362120) already locked by fs/dcache.c/909


Version-Release number of selected component (if applicable):
kernel-2.6.9-1.698_FC3
xorg-x11-6.8.1-12.FC3.21

How reproducible:
don't know
Comment 1 Jens Petersen 2004-12-09 02:28:54 EST
I can reproduce this too (on my Dell i865 box).
Comment 4 Kristian Høgsberg 2004-12-10 13:30:43 EST
Could you please post some more details about you system, in
particular:  the X.org log file (/var/log/Xorg.0.log), the kernel and
xorg-x11 RPM versions, output from lspci -v.  What kind of CPU is in
your machine?

Also, could you try to see if you can reproduce it by logging in and
out a few times?  I that doesn't do it, try to do

  killall -HUP X

from an X session. Thanks.
Comment 5 Davide Rossetti 2004-12-13 09:23:12 EST
Created attachment 108442 [details]
lspic -vvx

my laptop is a Asus L1400. PIII 1GHz 512MB
Comment 6 Davide Rossetti 2004-12-13 09:25:20 EST
Created attachment 108443 [details]
X11 log with kernel 2.6.9-1.681_FC3
Comment 7 Davide Rossetti 2004-12-13 09:39:26 EST
Created attachment 108444 [details]
content /var/log/messages 

first hundreds of lines contains the OOPS from 2.6.9-1.681_RC3
Comment 8 Davide Rossetti 2004-12-13 09:40:57 EST
actually my laptop has only 384MB of RAM

lapnardo 15:37 (54) ~>free
             total       used       free     shared    buffers     cached
Mem:        377920     222044     155876          0      10988     124568
-/+ buffers/cache:      86488     291432
Swap:       393552          0     393552
Comment 9 Davide Rossetti 2004-12-13 09:42:08 EST
Created attachment 108445 [details]
cat /proc/cpuinfo
Comment 10 Davide Rossetti 2004-12-13 09:44:54 EST
during the lock, my telnet session frezeezes as well.
the laptop fan does a lot of noise, maybe indication the CPU is in a
heat-producing busyloop somewhere...
Comment 11 Davide Rossetti 2004-12-13 09:45:50 EST
the sequence alt-sysrq-s + alt-sysrq-b succesfully reboots the laptop.
Comment 12 Davide Rossetti 2004-12-13 11:09:03 EST
some more comments:

1) Previous tries are with KDE desktop.
I tried with a Gnome desktop login and it locks as well. this time
there is the CAPS-lock led blinking

2) during lock, ping does not reach the laptop:

ronin 15:54 (62) apelink/driver>ping lapnardo
PING lapnardo.ape (10.0.0.41) 56(84) bytes of data.

--- lapnardo.ape ping statistics ---
3 packets transmitted, 0 received, 100% packet loss, time 1999ms

3) alt-sysrq-b succesfully reboots 
Comment 15 Kristian Høgsberg 2005-01-12 13:55:11 EST
This looks like it is caused by a bug in 4g4g kernel patch that was
recently resolved.  Could you please try to upgrade your kernel to the
latest FC3 update kernel (2.6.10-1.737 as of this writing) and see if
the problem persists.

Thanks.
Comment 16 Kristian Høgsberg 2005-01-18 17:50:01 EST
Ping?  Could you please try out a newer kernel and see if the problem
persists?  I'll close this bug if I don't hear anything in a week or
so, but please feel free to reopen if you encounter the problem after
this.

Thanks,
Kristian
Comment 17 Davide Rossetti 2005-01-19 10:31:26 EST
it seems to be fixed in 2.6.10-1.737_FC3
Comment 18 Kristian Høgsberg 2005-01-19 11:23:16 EST
OK, that's good news, I'll close the bug now.
Davide, thanks for reporting back on this.

Kristian

Note You need to log in before you can comment on or make changes to this bug.