Bug 142241 - libxslt-devel: remove .la files or fix Requires
Summary: libxslt-devel: remove .la files or fix Requires
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: libxslt   
(Show other bugs)
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Daniel Veillard
QA Contact:
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-08 14:43 UTC by Rex Dieter
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version: 1.1.13-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-08 13:32:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Rex Dieter 2004-12-08 14:43:27 UTC
/usr/lib/libexslt.la contains:
dependency_libs=' -lgcrypt -lgpg-error ...

So, either
1.  Remove all /usr/lib/lib*.la files from the package (preferred)
or
2.  Add to -devel subpkg:
Requires: libgcrypt-devel
Requires: libgpg-error-devel

Comment 1 Daniel Veillard 2005-03-14 16:49:18 UTC
Both fixed on rawhide,

 thanks,

Daniel

Comment 2 Rex Dieter 2005-12-01 16:06:17 UTC
FYI, the brokenness described here is also present in libxslt from FC4/RHEL4
(and I think FC3, but I don't have a box to check) -> Reopening, retargetting FC4.

For these, the best fix is option 2 so as not to introduce any binary
incompatibility.

Comment 3 Daniel Veillard 2006-06-08 12:33:30 UTC
Won't fix for FC4, sorry, fixed in FC5

Daniel

Comment 4 Rex Dieter 2006-06-08 12:50:08 UTC
> Won't fix for FC-4

The dependancies at least do appear to be fixed... at least in cvs,
libxslt/FC-4/libxslt.spec includes for -devel subpkg:
Requires: libgcrypt-devel

However, the latest RHEL4 release (libxslt-1.1.11-1 that I can see) is still
broken wrt this.  (Geesh, do I really have to file a separate bug for *every*
release?).  Reopening, targeting -> RHEL4 this time.

Comment 5 Daniel Veillard 2006-06-08 13:32:06 UTC
I won't change a RHEL4 package and go though the work of going though a
RHEL4 update process without an existing breakage on an app which can
be identified clearly and reported as a customer serious problem. 
So, to be honnest I don't expect to push an update for RHEL4 due to this, 

Daniel 


Note You need to log in before you can comment on or make changes to this bug.