Bug 142243 - remove .la files
Summary: remove .la files
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libxml2   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Veillard
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-08 14:46 UTC by Rex Dieter
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version: 2.6.18-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-14 16:47:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Rex Dieter 2004-12-08 14:46:43 UTC
Remove the unneccesary /usr/lib/lib*.la file(s) from the package. 
They're not needed, and can potentially result in dependancy
complications (see bug #142241 for one example).

Comment 1 Daniel Veillard 2005-03-14 16:47:39 UTC
Done, fixed in rawhide, bug duplicate of previous bug,

Daniel

Comment 2 Mephisto 2005-04-09 13:59:22 UTC
not needed??

i just tried building xine, and it ends with this:

grep: /usr/lib/libxml2.la: No such file or directory
/bin/sed: can't read /usr/lib/libxml2.la: No such file or directory
libtool-nofpic: link: `/usr/lib/libxml2.la' is not a valid libtool archive

how can you say its not needed then?

please put it back, it wont do anyone any harm...

Comment 3 Michael Schwendt 2005-04-09 14:17:58 UTC
You should not have a reference to /usr/lib/libxml2.la anywhere.


Note You need to log in before you can comment on or make changes to this bug.