Bug 142254 - Userhelper sometimes terminates before its child - it gets orphaned
Summary: Userhelper sometimes terminates before its child - it gets orphaned
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: usermode   
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-08 16:02 UTC by Tomas Mraz
Modified: 2013-07-02 23:03 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-27 16:03:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Trivial patch (545 bytes, patch)
2004-12-09 20:26 UTC, Tomas Mraz
no flags Details | Diff

Description Tomas Mraz 2004-12-08 16:02:55 UTC
Userhelper sometimes terminates before its child - it gets orphaned
and is unable to access it's controlling terminal.

Typically it happens if you run authconfig again just after running it.

It isn't 100% reproducible so you have to try it a few times before it
happens.

Comment 1 Tomas Mraz 2004-12-09 20:24:27 UTC
Hmmm a typical race condition. consolehelper thinks that it writes to
a pipe to userhelper but it is already closed if the exec call is fast
enough. So it gets SIGPIPE and exits.


Comment 2 Tomas Mraz 2004-12-09 20:26:29 UTC
Created attachment 108256 [details]
Trivial patch

Don't make any response to exec or exec fail messages.

Comment 3 Jindrich Novy 2005-01-27 16:03:49 UTC
Tomas, the fix is applied since usermode-1.78-1, thanks.


Note You need to log in before you can comment on or make changes to this bug.