Bug 142288 - messages.1:Dec 2 14:26:23 hostname kernel: RPC: bad TCP reclen 0x47455420 (non-terminal)
messages.1:Dec 2 14:26:23 hostname kernel: RPC: bad TCP reclen 0x47455420 (n...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-08 14:28 EST by George
Modified: 2007-11-30 17:07 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-22 13:13:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
tg3-update-rhel3-u3.patch (69.28 KB, patch)
2004-12-10 10:50 EST, John W. Linville
no flags Details | Diff

  None (edit)
Description George 2004-12-08 14:28:33 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.3)
Gecko/20040924

Description of problem:
The message 
hostname kernel: RPC: bad TCP reclen 0x47455420 (non-terminal)

frequently appears in /var/log/message

Version-Release number of selected component (if applicable):
kernel-smp-2.4.21-20.EL

How reproducible:
Didn't try


Additional info:
Comment 1 Ernie Petrides 2004-12-08 16:05:48 EST
Looks like memory corruption, specifically ASCII characters "GET " (or
maybe " TEG", depending on byte gender) in the "sk_reclen" field of an
"svc_sock" structure as detected by svc_tcp_recvfrom().

Could you please provide the output of "lsmod" and information about
the network driver and hardware in use on the machine(s) producing
these error messages?
Comment 2 George 2004-12-08 16:17:24 EST
It is a dell PE 2650 with dual processors. HT is enabled. network driver is tg3.
Thanks.

# cat /proc/cpuinfo
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 15
model           : 2
model name      : Intel(R) XEON(TM) CPU 2.40GHz
stepping        : 4
cpu MHz         : 2390.530
cache size      : 512 KB
physical id     : 0
siblings        : 2
runqueue        : 0
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm
bogomips        : 4771.02

processor       : 1
vendor_id       : GenuineIntel
cpu family      : 15
model           : 2
model name      : Intel(R) XEON(TM) CPU 2.40GHz
stepping        : 4
cpu MHz         : 2390.530
cache size      : 512 KB
physical id     : 3
siblings        : 2
runqueue        : 1
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm
bogomips        : 4771.02

processor       : 2
vendor_id       : GenuineIntel
cpu family      : 15
model           : 2
model name      : Intel(R) XEON(TM) CPU 2.40GHz
stepping        : 4
cpu MHz         : 2390.530
cache size      : 512 KB
physical id     : 0
siblings        : 2
runqueue        : 0
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm
bogomips        : 4771.02

processor       : 3
vendor_id       : GenuineIntel
cpu family      : 15
model           : 2
model name      : Intel(R) XEON(TM) CPU 2.40GHz
stepping        : 4
cpu MHz         : 2390.530
cache size      : 512 KB
physical id     : 3
siblings        : 2
runqueue        : 1
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm
bogomips        : 4771.02

[root@iffdp2 root]# cat /proc/meminfo
        total:    used:    free:  shared: buffers:  cached:
Mem:  2104729600 2046353408 58376192        0 280281088 1348206592
Swap: 4194811904 21966848 4172845056
MemTotal:      2055400 kB
MemFree:         57008 kB
MemShared:           0 kB
Buffers:        273712 kB
Cached:        1309972 kB
SwapCached:       6636 kB
Active:        1397692 kB
ActiveAnon:     109880 kB
ActiveCache:   1287812 kB
Inact_dirty:    253028 kB
Inact_laundry:   53752 kB
Inact_clean:     31668 kB
Inact_target:   347228 kB
HighTotal:     1179520 kB
HighFree:        13932 kB
LowTotal:       875880 kB
LowFree:         43076 kB
SwapTotal:     4096496 kB
SwapFree:      4075044 kB
HugePages_Total:     0
HugePages_Free:      0
Hugepagesize:     2048 kB

# lsmod
Module                  Size  Used by    Not tainted
loop                   12696   0
nfsd                   85168   8  (autoclean)
iptable_filter          2412   0  (autoclean) (unused)
ip_tables              16544   1  [iptable_filter]
nfs                    99376   5  (autoclean)
lockd                  58992   1  (autoclean) [nfsd nfs]
sunrpc                 89212   1  (autoclean) [nfsd nfs lockd]
lp                      9124   0  (autoclean)
parport                38816   0  (autoclean) [lp]
autofs4                16952   6  (autoclean)
tg3                    65832   2
floppy                 57488   0  (autoclean)
sg                     37228   0  (autoclean)
microcode               6848   0  (autoclean)
ext3                   89960   7
jbd                    55060   7  [ext3]
aacraid                49920   9
sd_mod                 13712  18
scsi_mod              114344   3  [sg aacraid sd_mod]
Comment 3 John W. Linville 2004-12-10 10:50:25 EST
Created attachment 108321 [details]
tg3-update-rhel3-u3.patch

This patch updates the tg3 driver to what is currently in RHEL3 U4.  Please
apply this patch then try to recreate.	Please post the results -- thanks!
Comment 4 John W. Linville 2005-01-10 10:17:56 EST
Any word on the effectiveness of the above patch?  And/or if the
problem persists in RHEL3 U4?
Comment 5 John W. Linville 2005-02-22 13:13:54 EST
Closing due to lack of response...please reopen when/if feedback is
available and if the problem persists in the latest RHEL3...

Note You need to log in before you can comment on or make changes to this bug.