Bug 142345 - idled binary missing
Summary: idled binary missing
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: cyrus-imapd   
(Show other bugs)
Version: 3
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: John Dennis
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-09 03:07 UTC by Andrew Baumann
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-10 20:38:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andrew Baumann 2004-12-09 03:07:21 UTC
The /usr/lib/cyrus-imapd/idled program (which is needed for proper 
IMAP IDLE support) is missing. The documentation refers to idled, the 
manpage for idled is there, and /etc/cyrus.conf has a (commented out) 
entry for starting idled, but the binary itself is absent. 
 
Version-Release number of selected component: 
cyrus-imapd-2.2.10-3.fc3

Comment 1 Simon Matter 2004-12-17 16:56:17 UTC
Here is why I don't enable idled in the Invoca rpms, which the RedHat
packages are derived from:
http://asg.web.cmu.edu/archive/message.php?mailbox=archive.info-cyrus&msg=19209

Comment 2 Andrew Baumann 2004-12-20 00:51:58 UTC
So, if you compile idled and don't use it you get noise in the logs. 
Fair enough, but I'd add that apart from outlook, mozilla/thunderbird 
now supports IDLE, as does the gnome mail-notification applet. Proper 
IDLE support is nice, because you get instant notification of mail 
arriving, and polling is pretty dumb if you can avoid it. 
 
If you don't compile with idle, then I think it is a bug to install 
the manual page and refer to it in the config file. 

Comment 3 Simon Matter 2004-12-20 13:44:23 UTC
It's fixed in the current Invoca rpm now. Which means no idled related
files are installed until you build the binary rpms with the idled
option enabled. The commented out line in cyrus.conf will stay there
because it's the distributed config from the cyrus-imapd package.
However I'll not include idled support in the default config until
some really large sites with very mixed client environment confirm
that it works without any problems.

Comment 4 Simon Matter 2005-01-21 06:23:33 UTC
The current Invoca rpm 2.2.10-10 now enables IDLED support by default.
I didn't get any negative report so far so I expect things to works
quite well and I'm quite sure it will also show up in the next RedHat
release.


Comment 5 John Dennis 2005-02-10 20:38:11 UTC
This will show up in the next fedora release, FC4


Note You need to log in before you can comment on or make changes to this bug.