Bug 142367 - incorrect information on spec file
incorrect information on spec file
Product: Fedora
Classification: Fedora
Component: kdeedu (Show other bugs)
All Linux
medium Severity low
: ---
: ---
Assigned To: Ngo Than
Depends On:
  Show dependency treegraph
Reported: 2004-12-09 04:52 EST by Luis
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-02-01 08:19:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Luis 2004-12-09 04:52:04 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
the kdeedu.spec file constains the following errors
kgeo is no more in the kdeedu project, it has been replaced by kig

< Provides: kgeo
> Provides: kig

< %package -n kgeo
> %package -n kig

< %description -n kgeo
> %description -n kig

The following is not a bug but in the %configure section I would wish
to remove the --disable-kig-python-scripting flag, now it is safe to
compile or work with python scripting because of the new bison
version. It is a really good feature of kig. But in that case we will
need bison for compilation and the package itself

> Requires: bison >=1.875c-2 #current version
> Buildrequires: bison>=1.875c-2

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. less kdeedu.spec

Additional info:
Comment 1 Luis 2004-12-09 08:26:40 EST
I made a mistake it is not bison package it is boost

Requires: boost >=1.32.0
Buildrequires: boost-devel >=1.32.0
Comment 2 Ngo Than 2005-02-01 08:19:27 EST
i have fixed kgeo issue in the kdeedu-3.3.1-2.2. I will remove the
option --disable-kig-python-scripting for FC4, but not for FC3. Thanks
for your report.

Note You need to log in before you can comment on or make changes to this bug.