Bug 142373 - yum ignores --download-only flag
yum ignores --download-only flag
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
3
All Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-09 05:53 EST by Derek Poon
Modified: 2014-09-16 12:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-14 02:37:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Derek Poon 2004-12-09 05:53:57 EST
Description of problem:
In yum 2.0.7 (FC2), there was a --download-only flag:

# yum --help

    Usage:  yum [options] <update | upgrade | install | info | remove
| list |
            clean | provides | search | check-update | groupinstall |
groupupdate |
            grouplist >

         Options:
          -c [config file] - specify the config file to use
          -e [error level] - set the error logging level
          -d [debug level] - set the debugging level
          -y answer yes to all questions
          -t be tolerant about errors in package commands
          -R [time in minutes] - set the max amount of time to
randomly run in.
          -C run from cache only - do not update the cache
          --installroot=[path] - set the install root (default '/')
          --version - output the version of yum
          --exclude=some_pkg_name - packagename to exclude - you can use
            this more than once
          --download-only - only download packages - do not run the
transaction
          -h, --help this screen


However, in yum 2.1.11 (FC3), the --download-only flag is gone:

# yum --help

    Usage:  yum [options] < update | install | info | remove | list |
            clean | provides | search | check-update | groupinstall |
            groupupdate | grouplist | groupinfo | groupremove |
generate-rss |
            makecache | localinstall >

        Options:
        -c [config file] - specify the config file to use
        -e [error level] - set the error logging level
        -d [debug level] - set the debugging level
        -y - answer yes to all questions
        -R [time in minutes] - set the max amount of time to randomly
run in
        -C run from cache only - do not update the cache
        --installroot=[path] - set the install root (default '/')
        --version - output the version of yum
        --rss-filename=[path/filename] - set the filename to generate
rss to
        --exclude=package to exclude
        --disablerepo=repository id to disable (overrides config file)
        --enablerepo=repository id to enable (overrides config file)

        -h, --help  - this screen

Version-Release number of selected component (if applicable):
yum-2.1.11-3

How reproducible:
Always

Steps to Reproduce:
Run
  yum --download-only -y update

Actual Results:  Packages that need to be updated are downloaded _and_
_automatically_ _installed_.

Expected Results:  Yum should continue to honor the --download-only
flag that was supported in previous versions: packages that need to be
updated would be downloaded to the cache directory and not be installed.

Alternatively, if there was a conscious decision to remove support for
the --download-only flag, then the presence of the flag should be a
fatal error.

In any case, it is not acceptable to silently ignore an unrecognized
flag and upgrade packages when the user clearly specified to download
only.

Additional info:

The yum.conf man page indicates that support for the download-only
directive has also been removed.  The presence of a download-only
directive in yum.conf should either be honored or cause a fatal error.

Classifying as High Severity because unexpected upgrading of packages
is data loss.
Comment 1 Derek Poon 2004-12-10 06:28:12 EST
yum-2.1.12-9.fc3 complains that the --download-only flag is
unrecognized, which is an acceptable behavior.

Options Error: option --download-only not recognized

    Usage:  yum [options] < update | install | info | remove | list |
            clean | provides | search | check-update | groupinstall | 
            groupupdate | grouplist | groupinfo | groupremove |
generate-rss
|
            makecache | localinstall >
Comment 2 Seth Vidal 2004-12-14 02:37:39 EST
okay, closing.

Note You need to log in before you can comment on or make changes to this bug.