Bug 142375 - yum cron job spews huge e-mails
yum cron job spews huge e-mails
Status: CLOSED DUPLICATE of bug 139021
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-09 06:14 EST by Derek Poon
Modified: 2014-01-21 17:50 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Derek Poon 2004-12-09 06:14:58 EST
Description of problem:
The yum cron job runs extremely verbosely, causing cron to send
unreadably huge e-mails to root.  When running under cron, yum should
reduce its verbosity.  (I think it should be possible to detect that
there is no terminal attached?)

Version-Release number of selected component (if applicable):
yum-2.1.11-3

How reproducible:
Always

Steps to Reproduce:
1. Enable yum cron job
2. Wait for an update
3. See huge e-mail sent by cron to root.

Actual results:
I got this 92kB e-mail this morning, with just four packages being
updated:

  Date: Thu,  9 Dec 2004 05:20:46 +0100 (CET)
  From: Cron Daemon <root@linus.dwp>
  To: root@linus.dwp
  Subject: Cron <root@linus> run-parts /etc/cron.daily

  /etc/cron.daily/yum.cron:


  Updating: Omni 0 % done 1/8
  Updating: Omni 0 % done 1/8
  Updating: Omni 0 % done 1/8
  Updating: Omni 0 % done 1/8
  Updating: Omni 0 % done 1/8
  Updating: Omni 0 % done 1/8
  Updating: Omni 0 % done 1/8
  Updating: Omni 0 % done 1/8
  Updating: Omni 0 % done 1/8
  Updating: Omni 0 % done 1/8
    [...]
  Updating: shadow-utils 99 % done 4/8
  Updating: shadow-utils 99 % done 4/8
  Updating: shadow-utils 100 % done 4/8
  Completing update for Omni-foomatic  - 5/8
  Completing update for jpackage-utils  - 6/8
  Completing update for shadow-utils  - 7/8
  Completing update for Omni  - 8/8


Expected results:
If no updates are needed, yum should generate no output.  If updates
are needed, then an appropriate level of verbosity would be:

  /etc/cron.daily/yum.cron:

  Updated package Omni-foomatic-0.9.1-6.i386.rpm =>
Omni-foomatic-0.9.1-7.i386.rpm
  Updated package jpackage-utils-1.5.38-1jpp_3rh.noarch.rpm =>
jpackage-utils-1.6.1-1jpp
  Updated package shadow-utils-4.0.3-21.i386.rpm =>
shadow-utils-4.0.3-40.i386.rpm
  Updated package Omni-0.9.1-6.i386.rpm => Omni-0.9.1-7.i386.rpm
Comment 1 Seth Vidal 2004-12-09 08:32:37 EST
Install yum 2.1.12 from updates-testing.

Duplicate

*** This bug has been marked as a duplicate of 139021 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:07:38 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.