Bug 142417 - rsh-server does not accept a username larger than 8 characters
Summary: rsh-server does not accept a username larger than 8 characters
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: rsh   
(Show other bugs)
Version: 3.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Karel Zak
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-09 17:09 UTC by John Gibb
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-24 12:36:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John Gibb 2004-12-09 17:09:52 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
We are a software development house and are currently using MKS
Toolkit 7.5 on Windows 2000 to interface with RedHat Linux via rsh to
build applications.

MKS Toolkit uses it's own rsh.exe binary which uses 'id' to provide
the source login username. Because the connection is coming from a
Windows system, the username is specified as DOMAIN\username (as
verified when typing 'id' on the Windows MKS Toolkit development
environment) and all rsh-servers can handle this, however RedHat
rsh-server-0.17-17, does not accept a username larger than 8
characters and as such generates a message "remuser too long".

Please note that a .rhost exists on the destination RedHat server.

MKS $ id -u -n
DOMAIN\develop
MKS $ rsh redhat1 -l srcdevel ls
remuser too long
MKS $


Is there a workwaround or will rsh-server be updated not to reject
usernames larger than 8 characters ?

Version-Release number of selected component (if applicable):
rsh-server-0.17-17

How reproducible:
Always

Steps to Reproduce:
1. rsh redhat1 -l nslivsrc ls
2. 
3.
    

Additional info:

Comment 1 Karel Zak 2004-12-10 13:59:10 UTC
I see 16 bytes limit in all rshd versions and 32 bytes in rlogin.

For example 12bytes username:

$ id
uid=503(longusername) gid=503(longusername) skupiny=503(longusername) 

$ /usr/bin/rsh petra -l zakkr ls
Desktop
Mail
OpenOffice.org1.1.3


Comment 2 Karel Zak 2005-01-24 12:36:12 UTC
No feedback ... closing as not a bug.


Note You need to log in before you can comment on or make changes to this bug.