Bug 142431 - Bad file modes in some postgresql-* subpackages
Summary: Bad file modes in some postgresql-* subpackages
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: postgresql (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Tom Lane
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords: EasyFix, Patch
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-09 18:04 UTC by Ville Skyttä
Modified: 2013-07-03 03:03 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-17 16:44:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix permissions, against 7.4.6-2 in devel (1.94 KB, patch)
2004-12-09 18:04 UTC, Ville Skyttä
no flags Details | Diff

Description Ville Skyttä 2004-12-09 18:04:24 UTC
postgresql-devel, postgresql-python and postgresql-jdbc contain spurious
executable bits for some files.  Fix attached.

Comment 1 Ville Skyttä 2004-12-09 18:04:24 UTC
Created attachment 108240 [details]
Fix permissions, against 7.4.6-2 in devel

Comment 2 Tom Lane 2004-12-16 21:42:36 UTC
Hmm, I don't think you got the .py file permissions quite right ---
I'd suppose that the ones with /usr/bin/python headers ought to be
executable.  The other changes look good though.  Thanks!

Comment 4 Ville Skyttä 2004-12-16 22:06:44 UTC
Yes... but that's exactly how the patch is supposed to behave.  The
only *.py that "need" execute permissions are advanced.py and
basics.py, both in tutorial/

All others (pg*.py in site-packages, func.py and syscat.py in
tutorial/) should not need that, they're libraries, not scripts.

Comment 5 Tom Lane 2004-12-16 22:40:58 UTC
The patch as given zapped setup.py, and didn't zap the non-executable
files in tutorial/.  Maybe you intended chmod 644 ...
PyGreSQL/tutorial/*.py rather than PyGreSQL/*.py?

Comment 6 Ville Skyttä 2004-12-16 22:51:46 UTC
Yes, exactly.  Guilty as charged, and thanks for the sanity check.

Comment 9 Tom Lane 2004-12-17 16:44:22 UTC
Patch applied in this morning's releases (7.4.6-1.FC?.2).  Thanks for
spotting the problem.


Note You need to log in before you can comment on or make changes to this bug.