Bug 142434 - popt-1.9.1-21 (which is newer than popt-1.9.1-8) is already installed
Summary: popt-1.9.1-21 (which is newer than popt-1.9.1-8) is already installed
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
: 143549 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-09 18:31 UTC by Robert Scheck
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-07 19:37:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Robert Scheck 2004-12-09 18:31:09 UTC
Description of problem:
I tried a upgrade from FC3 to devel which died with:

Preparing...                ########################################### [100%]
        package popt-1.9.1-21 (which is newer than popt-1.9.1-8) is already installed

Version-Release number of selected component (if applicable):
rpm-4.3.3-8
popt-1.9.1-8

How reproducible:
Everytime, see above.

Actual results:
No upgrade of RPM possible.

Expected results:
Upgrade of RPM should be possible.

Comment 1 Jeff Johnson 2004-12-10 01:24:24 UTC
Yup, popt versipon needs to change from 1.9.1 to 1.9.3,
thanks for the reminder.

No matter what, the actual bits in the library have not
changed at all.

Comment 2 Jeff Johnson 2004-12-29 11:04:16 UTC
*** Bug 143549 has been marked as a duplicate of this bug. ***

Comment 3 Axel Thimm 2004-12-29 11:14:22 UTC
> No matter what, the actual bits in the library have not
> changed at all.

Shouldn't popt be better outsourced from the rpm tarballs? It has
become a rather independent piece of source used by a lot of other
software bits, too. It also seems to have a very different development
pace than rpm itself including the versioning. And bumping up the
version w/o touching the code looks rather hackish.

If rpm still needs it in its tarball (instead of BuildRequiring it),
then remerge popt into rpm's tarball w/o creating popt packages out of
rpm.

Comment 4 Jeff Johnson 2004-12-29 23:56:32 UTC
popt is critically important to rpm functionality and will not
be separated. rpm uses popt more than any other program, and
I will not ever go back to external popt for rpm use.

Comment 5 Jeff Johnson 2005-02-07 19:37:06 UTC
Fixed in popt-1.10.1-0.18 (from rpm-4.4.1-0.18 build).


Note You need to log in before you can comment on or make changes to this bug.