Bug 14245 - GIMP segmentation fault during screen capture
Summary: GIMP segmentation fault during screen capture
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gimp   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
high
medium
Target Milestone: ---
Assignee: Matt Wilson
QA Contact:
URL:
Whiteboard: Winston rc1
Keywords:
: 14042 14739 15530 17141 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-07-18 20:32 UTC by John Cagle
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-22 16:46:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John Cagle 2000-07-18 20:32:21 UTC
GIMP 1.1.24 (1.3 Prerelease), running as root.

File...  Acquire... Screen Shot

Select any options and then click on the "Grab" button.

gimp: fatal error: Segmentation fault

Here's a stack trace:

gimp (pid:2493): [E]xit, [H]alt, show [S]tack trace or [P]roceed: S
#0  0x401ab9a4 in g_on_error_stack_trace () from /usr/lib/libglib-1.2.so.0
#1  0x401ab89f in g_on_error_query () from /usr/lib/libglib-1.2.so.0
#2  0x80b6b04 in gimp_fatal_error ()
#3  <signal handler called>
#4  0x815c23a in tile_manager_get ()
#5  0x8138168 in pixel_region_get_row ()
#6  0x8100a9f in layer_invalidate_previews ()
#7  0x8100485 in layer_linked ()
#8  0x8100551 in layer_preview ()
#9  0x817ce7e in gimp_image_construct_composite_preview ()
#10 0x810b057 in lc_dialog_update_image_list ()
#11 0x810ad55 in lc_dialog_preview_update ()
#12 0x400cb32f in gtk_menu_shell_forall () from /usr/lib/libgtk-1.2.so.0
#13 0x4007b768 in gtk_container_foreach () from /usr/lib/libgtk-1.2.so.0
#14 0x810ac4e in lc_dialog_flush ()
#15 0x401b125d in g_idle_dispatch () from /usr/lib/libglib-1.2.so.0
#16 0x401b00a4 in g_main_dispatch () from /usr/lib/libglib-1.2.so.0
#17 0x401b073f in g_main_iterate () from /usr/lib/libglib-1.2.so.0
#18 0x401b091c in g_main_run () from /usr/lib/libglib-1.2.so.0
#19 0x400c1667 in gtk_main () from /usr/lib/libgtk-1.2.so.0
#20 0x813a076 in plug_in_run ()
#21 0x8144ea7 in procedural_db_execute ()
#22 0x813a8bf in plug_in_set_menu_sensitivity ()
#23 0x813a2ee in plug_in_set_menu_sensitivity ()
#24 0x401ae73f in g_io_unix_dispatch () from /usr/lib/libglib-1.2.so.0
#25 0x401b00a4 in g_main_dispatch () from /usr/lib/libglib-1.2.so.0
#26 0x401b073f in g_main_iterate () from /usr/lib/libglib-1.2.so.0
#27 0x401b091c in g_main_run () from /usr/lib/libglib-1.2.so.0
#28 0x400c1667 in gtk_main () from /usr/lib/libgtk-1.2.so.0
#29 0x8110ed9 in main ()
#30 0x402e725f in __libc_start_main (main=0x8110540 <main>, argc=1,

Comment 1 John Cagle 2000-07-24 23:03:43 UTC
Not fixed in beta4.

Comment 2 Matt Wilson 2000-07-27 18:05:21 UTC
*** Bug 14739 has been marked as a duplicate of this bug. ***

Comment 3 Matt Wilson 2000-07-27 18:05:58 UTC
*** Bug 14042 has been marked as a duplicate of this bug. ***

Comment 4 Glen Foster 2000-07-30 23:07:07 UTC
This defect is considered MUST-FIX for Winston Release-Candidate #1

Comment 5 John Cagle 2000-07-31 15:50:01 UTC
Not fixed in pinstripe, although behaviour has changed slightly.
Segfault is not as repeatable, but screen capture never works.
I suggest removing the Acquire... feature for now.

Comment 6 Matt Wilson 2000-07-31 21:42:17 UTC
xwd is generating invalid xwd files.


Comment 7 Matt Wilson 2000-07-31 23:05:35 UTC
xwd is being miscompiled.


Comment 8 Dale Lovelace 2000-08-03 21:07:14 UTC
Fixed in XFree86-4.0.1-0.41.i386.rpm

Comment 9 Matt Wilson 2000-08-06 01:14:03 UTC
*** Bug 15530 has been marked as a duplicate of this bug. ***

Comment 10 Trond Eivind Glomsrxd 2000-08-22 16:44:31 UTC
Still fails for me.... newest everything as of Aug 22.

/usr/lib/gimp/1.1/plug-ins/screenshot: fatal error: Segmentation fault

#0  0x401be6e4 in g_on_error_stack_trace () from /usr/lib/libglib-1.2.so.0
#1  0x401be5f5 in g_on_error_query () from /usr/lib/libglib-1.2.so.0

#2  0x402e6b7a in gimp_plugin_sigfatal_handler ()
#3  <signal handler called>
#4  0x403766fc in chunk_free (ar_ptr=0x40418740, p=0x804ba4b) at malloc.c:3116
#5  0x40376474 in __libc_free (mem=0x804ba60) at malloc.c:3042
#6  0x402175f6 in _XFreeDisplayStructure () from /usr/X11R6/lib/libX11.so.6
#7  0x40207067 in XCloseDisplay () from /usr/X11R6/lib/libX11.so.6
#8  0x401832aa in gdk_exit_func () from /usr/lib/libgdk-1.2.so.0
#9  0x4032a4e6 in exit (status=0) at exit.c:57
#10 0x40316d8e in __libc_start_main (main=0x8049610 <main>, argc=6

24 bpp, XFree 4, TnT2

Comment 11 Matt Wilson 2000-08-24 01:26:16 UTC
Fixed in gimp-1.1.25-1


Comment 12 Matt Wilson 2000-08-31 18:05:15 UTC
*** Bug 17141 has been marked as a duplicate of this bug. ***

Comment 13 Matt Wilson 2000-08-31 20:52:33 UTC
*** Bug 17141 has been marked as a duplicate of this bug. ***

Comment 14 Matt Wilson 2000-08-31 21:11:27 UTC
*** Bug 17141 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.