Bug 1424830 - krita - unspecified Qt dependencies
Summary: krita - unspecified Qt dependencies
Status: CLOSED DUPLICATE of bug 1225749
Alias: None
Product: Fedora
Classification: Fedora
Component: krita
Version: 25
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-19 17:43 UTC by Jan Kalina
Modified: 2017-02-20 16:10 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-02-19 19:18:41 UTC


Attachments (Terms of Use)

Description Jan Kalina 2017-02-19 17:43:13 UTC
Description of problem:
Package krita-3.1.1-1.fc25.x86_64 has unspecified dependencies.
When installed, required Qt components are not installed.

Version-Release number of selected component:
krita-3.1.1-1.fc25.x86_64

Steps to Reproduce:
1. dnf install krita-3.1.1-1.fc25.x86_64
2. krita

Actual results:
krita: error while loading shared libraries: libQt5X11Extras.so.5: cannot open shared object file: No such file or directory

After manual installing qt5-qtx11extras:
krita: error while loading shared libraries: libKF5WindowSystem.so.5: cannot open shared object file: No such file or directory

After manual installing kf5-kwindowsystem:
krita.lib.pigment: Legacy integer arithmetics implementation
This application failed to start because it could not find or load the Qt platform plugin "xcb"
in "".
Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, xcb.
Reinstalling the application may fix this problem.
Aborted (core dumped)

Comment 1 Rex Dieter 2017-02-19 18:41:54 UTC
The fact the it links that little early should be enough to implicitly pull I the right package (s) that provides it.

I suspect you may have something else installed that is interfering.

Comment 2 Rex Dieter 2017-02-19 18:43:11 UTC
Yay phone autocorrect, 'little early' -> 'library'

Comment 3 Jan Kalina 2017-02-19 19:18:41 UTC
Thanks Rex, by "dnf repoquery --requires krita" krita has correct dependencies - it will be some krita unrelated problem - closing.

Comment 4 Rex Dieter 2017-02-20 14:59:28 UTC
For example, try this:

rpm -q --whatprovides 'libQt5X11Extras.so.5()(64bit)'

and 

rpm -q --whatprovides 'libKF5WindowSystem.so.5()(64bit)'

Comment 5 Jan Kalina 2017-02-20 15:42:37 UTC
Thanks. It was problem of "hipchat4" from non-fedora repo, which "provides" (but not provides, of course) mentioned libraries too.
Sorry for invalid report.

Comment 6 Rex Dieter 2017-02-20 16:08:21 UTC
OK, yeah, I wish hipchat would fix their rpm someday (I first reported the issue to them summer 2015):

See also,

https://plus.google.com/+RexDieter/posts/7awPKg4Mgw2

https://fedoraproject.org/wiki/Common_F22_bugs#third-party-rpms-bundle-qt5
https://bugzilla.redhat.com/show_bug.cgi?id=1225749

Comment 7 Rex Dieter 2017-02-20 16:10:50 UTC

*** This bug has been marked as a duplicate of bug 1225749 ***


Note You need to log in before you can comment on or make changes to this bug.