Bug 142512 - xmms crashes immediately on startup
xmms crashes immediately on startup
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xmms (Show other bugs)
3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Colin Walters
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-09 21:34 EST by Need Real Name
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-15 16:32:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2004-12-09 21:34:41 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040616

Description of problem:
When I run xmms it immediately crashes with a seg fault.  It says
"You've probably found a bug in XMMS, please visit
http://bugs.xmms.org and fill out a bug report".  This is on a
Thinkpad X40 using an out-of-the-box installation from the FC3 DVD.

Version-Release number of selected component (if applicable):
xmms-1.2.10-9

How reproducible:
Always

Steps to Reproduce:
1. Run xmms from the command line.  No args necessary
2.
3.
    

Actual Results:  Crashes immediately

Expected Results:  don't crash

Additional info:
Comment 1 Colin Walters 2004-12-13 17:01:01 EST
Can you get a stack trace?

http://fedora.linux.duke.edu/wiki/index.cgi/StackTraces

Be sure to get the xmms debuginfo rpm.
Comment 2 Need Real Name 2004-12-15 16:31:15 EST
This is very weird, XMMS doesn't crash any more, at least not
instantly.  It instead complains that it can't open the audio server,
but that's some other type of config issue.  I had rebooted/powered
down the box a couple of times since reporting the crash.  

I've seen other instances of strange behavior with this new FC3
install (on a newly acquired Thinkpad X40) so the xmms crashes I saw
may be the result of some more general instability, either from some
problem in FC3 itself, or with my installation, or maybe with my
hardware.  Basically something stops working until I reboot the box or
sometimes restart X, sort of like what happens with MS Windows
systems.  I've been running memtest86 on that box for the past 10
hours with no failures yet, but who knows what else might be wrong.

Anyway I'd say go ahead and close this; if it recurs, I'll try to
analyze it further and re-open if it looks appropriate.

Sorry about this.

Note You need to log in before you can comment on or make changes to this bug.