Bug 142542 - Taskomatic log issues
Taskomatic log issues
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site (Show other bugs)
rhn360
All Linux
medium Severity medium
: ---
: ---
Assigned To: Robin Norwood
Max Spevack
:
Depends On:
Blocks: 142012
  Show dependency treegraph
 
Reported: 2004-12-10 10:24 EST by Christopher M. Smith
Modified: 2007-04-18 13:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-28 13:45:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher M. Smith 2004-12-10 10:24:39 EST
Dec 10 10:21:55 scripts1 /usr/sbin/taskomatic[29469]: processing
user_id 3932601 (address 'amcle@doh.health.nsw.gov.au', state
'needs_verifying')
Dec 10 10:21:55 scripts1 /usr/sbin/taskomatic[29469]: Unable to
perform lookup on address 'RHN::EmailAddress=HASH(0x93f0bb8)';
skipping for now...
Dec 10 10:21:55 scripts1 /usr/sbin/taskomatic[29469]: processing
user_id 3932570 (address 'matrixchief@yahoo.com', state 'needs_verifying')
Dec 10 10:21:55 scripts1 /usr/sbin/taskomatic[29469]: Unable to
perform lookup on address 'RHN::EmailAddress=HASH(0x93c8a7c)';
skipping for now...
Dec 10 10:21:56 scripts1 /usr/sbin/taskomatic[29469]: processing
user_id 3932580 (address 'joyce_tu@acer.com.tw', state 'needs_verifying')
Dec 10 10:21:56 scripts1 /usr/sbin/taskomatic[29469]: Unable to
perform lookup on address 'RHN::EmailAddress=HASH(0x93f08c4)';
skipping for now...
Dec 10 10:21:56 scripts1 /usr/sbin/taskomatic[29469]: processing
user_id 3932601 (address 'amcle@doh.health.nsw.gov.au', state
'needs_verifying')
Dec 10 10:21:56 scripts1 /usr/sbin/taskomatic[29469]: Unable to
perform lookup on address 'RHN::EmailAddress=HASH(0x93f0e04)';
skipping for now...
Dec 10 10:21:56 scripts1 /usr/sbin/taskomatic[29469]: processing
user_id 3932570 (address 'matrixchief@yahoo.com', state 'needs_verifying')
Dec 10 10:21:56 scripts1 /usr/sbin/taskomatic[29469]: Unable to
perform lookup on address 'RHN::EmailAddress=HASH(0x93a1da4)';
skipping for now...
Dec 10 10:21:57 scripts1 /usr/sbin/taskomatic[29469]: processing
user_id 3932580 (address 'joyce_tu@acer.com.tw', state 'needs_verifying')
Dec 10 10:21:57 scripts1 /usr/sbin/taskomatic[29469]: Unable to
perform lookup on address 'RHN::EmailAddress=HASH(0x93f09b4)';
skipping for now...
Dec 10 10:21:57 scripts1 /usr/sbin/taskomatic[29469]: processing
user_id 3932601 (address 'amcle@doh.health.nsw.gov.au', state
'needs_verifying')
Dec 10 10:21:57 scripts1 /usr/sbin/taskomatic[29469]: Unable to
perform lookup on address 'RHN::EmailAddress=HASH(0x93f1554)';
skipping for now...
Dec 10 10:21:57 scripts1 /usr/sbin/taskomatic[29469]: processing
user_id 3932570 (address 'matrixchief@yahoo.com', state 'needs_verifying')
Dec 10 10:21:57 scripts1 /usr/sbin/taskomatic[29469]: Unable to
perform lookup on address 'RHN::EmailAddress=HASH(0x93f0bac)';
skipping for now...

Writes these 1/second.  Needs to stop.  Filing in this fashion per
Chip Turner.
Comment 1 Robin Norwood 2005-01-04 16:56:32 EST
There are two messages here:

Dec 10 10:21:55 scripts1 /usr/sbin/taskomatic[29469]: processing
user_id 3932601 (address 'amcle@doh.health.nsw.gov.au', state
'needs_verifying')

And:

Dec 10 10:21:55 scripts1 /usr/sbin/taskomatic[29469]: Unable to
perform lookup on address 'RHN::EmailAddress=HASH(0x93f0bb8)';
skipping for now...

For the first, I've changed the code so that this message is displayed
if the debug level is set to 'debug' or higher (it was set to output
that message during normal operations). 

This issue is fixed in CVS.

The second message is a symptom of a different problem - described in
bug #144178
Comment 2 Todd Warner 2005-01-10 16:55:41 EST
I'm an idiot... these are not ON_QA... they are QA_READY.
Comment 3 Max Spevack 2005-01-10 17:07:49 EST
Robin, please comment on the best way for QA to verify that these
issues are fixed.  Thanks.
Comment 4 Robin Norwood 2005-01-11 12:51:03 EST
Test plan:

Have your friendly neighborhood sysadmin run the following commands on
the scripts box of the environment you are testing (ie, the box that
is running taskomatic):

# service taskomatic status
(expect: taskomatic (pid 18008) is running...)

# grep 'processing user_id' /var/log/messages
(expect:
...
Jan 11 12:45:17 scripts /usr/sbin/taskomatic[18008]: processing
user_id 3932570 (address 'matrixchief@yahoo.com', state 'needs_verifying')
Jan 11 12:45:18 scripts /usr/sbin/taskomatic[18008]: processing
user_id 3932580 (address 'joyce_tu@acer.com.tw', state 'needs_verifying')
Jan 11 12:45:18 scripts /usr/sbin/taskomatic[18008]: processing
user_id 3932601 (address 'amcle@doh.health.nsw.gov.au', state
'needs_verifying')
Jan 11 12:45:18 scripts /usr/sbin/taskomatic[18008]: processing
user_id 3932570 (address 'matrixchief@yahoo.com', state 'needs_verifying')
)
Should be lots and lots of output, about one a second, up until the
time that taskomatic was restarted after the code was pushed to this
box.  If the messages are still occuring, you should just to make sure
that taskomatic was restarted after packges were updated.
Comment 5 Todd Warner 2005-01-21 10:02:41 EST
Mass move to ON_QA for the QA push two days ago.
Comment 6 Max Spevack 2005-01-24 14:07:48 EST
Verified with Chris -- none of these error messages since the push to QA.

PROD_READY

Note You need to log in before you can comment on or make changes to this bug.