Bug 142557 - SRPM in Rawhide is missing build-requires for elfutils-libelf-devel
SRPM in Rawhide is missing build-requires for elfutils-libelf-devel
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: net-snmp (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Vokal
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-10 12:01 EST by Joe Christy
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-13 04:54:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Christy 2004-12-10 12:01:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
rpmbuild dies in config, giving errors:
...
checking for SNMP support... yes, shared
checking OpenSSL dir for SNMP... no
checking for snmp_parse_oid in -lnetsnmp... no
checking for init_snmp in -lnetsnmp... no
configure: error: SNMP sanity check failed. Please check config.log
for more inf
ormation.
error: Bad exit status from /usr/local/rpm/tmp/rpm-tmp.92234 (%build)


RPM build errors:
    Bad exit status from /usr/local/rpm/tmp/rpm-tmp.92234 (%build)

This turns out to refer to .../BUILD/php-5.0.2/build-cgi/config.log,
which (I'm sorry to say I just overwrote that log, having fixed the
problem locally, so no actual output) is dying trying to compile an
SNMP test program because it can't find the libelf.h header.

Version-Release number of selected component (if applicable):
php-5.0.2-8.src.rpm

How reproducible:
Always

Steps to Reproduce:
1. Be sure that elfutils-libelf-devel isn't installed
2. rpm -ivh php-5.0.2-8.src.rpm
3. rpmbuild -ba php.spec
    

Actual Results:  rpmbuild doesn't complain about the missing
build-requires; it simply dies during config as per my description.

Expected Results:  rpmbuild complains about missing build-requires
_before_ moving on to config

Additional info:

Installing elfutils-libelf-devel allows rpmbuild to succeed.
Comment 1 Joe Christy 2004-12-10 12:03:48 EST
PS I hate the new bug writing wizard, which demeans my intelligence at
the same time it allowed me to submit the bug report without knowing
that the package that it refers to is buried deep within the report
instead of somewhere obvious at the beginning.
Comment 2 Joe Orton 2004-12-10 12:07:55 EST
Sounds like Requires: elfutils-libelf-devel is missing in netsnmp-devel.
Comment 3 Joe Orton 2004-12-10 12:10:53 EST
If you don't like the Wizard interface then use the "Expert"
interface, BTW.  I have a firefox keyword bookmark for:

https://bugzilla.redhat.com/bugzilla/enter_bug.cgi?product=Fedora+Core&component=%s

so that I just type "newbug php" in the URL bar to enter a PHP bug
report against raw hide.

Comment 4 Radek Vokal 2004-12-13 04:54:21 EST
Joe, may I have your net-snmp version. net-snmp-devel requires
elfutils-libelf-devel. I've fixed this in net-snmp-devel-5.1.2-4. 

Note You need to log in before you can comment on or make changes to this bug.