Bug 142648 - system-config-* tools only work through ssh with sudo when used without consolehelper
system-config-* tools only work through ssh with sudo when used without conso...
Status: CLOSED DUPLICATE of bug 164671
Product: Fedora
Classification: Fedora
Component: sudo (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karel Zak
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-11 10:18 EST by Thorsten Leemhuis
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-09 15:42:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thorsten Leemhuis 2004-12-11 10:18:10 EST
Description of problem:
When i connect to a machine with "ssh -Y machine" and then use a command like
"system-config-network" the X11 connection rejectes because of wrong
authentication. Using the tools without consolehelper works fine.

Version-Release number of selected component (if applicable):
usermode-1.74-1

How reproducible:
Always

Steps to Reproduce:
$ sudo system-config-network
-> Works as expected 
$ ssh -Y localhost
$ sudo system-config-network
X11 connection rejected because of wrong authentication.
The application 'system-config-network-gui' lost its connection to the display
localhost:10.0;
most likely the X server was shut down or you killed/destroyed
the application.
$ sudo /usr/bin/system-config-network
X11 connection rejected because of wrong authentication.
The application 'system-config-network-gui' lost its connection to the display
localhost:10.0;
most likely the X server was shut down or you killed/destroyed
the application.
$ ls -l /usr/bin/system-config-network
lrwxrwxrwx  1 root root 13  2. Nov 18:19 /usr/bin/system-config-network ->
consolehelper
$ sudo /usr/sbin/system-config-network
-> works fine
Comment 1 David Juran 2005-06-20 04:20:38 EDT
This behaviour is of course present in RHEL4 as well.
Comment 2 Thorsten Leemhuis 2005-06-20 04:26:49 EDT
And still in FC4 also -- changing component from FC3 to FC4
Comment 3 Thorsten Leemhuis 2005-11-18 14:32:00 EST
Still present in rawhide as of today. Changing component from FC4 to devel.
Comment 4 Thorsten Leemhuis 2006-04-01 02:52:31 EST
Ping -- still in FC5. Is there any chance we could get this fixed? Jindrich, or
is this is the wrong component?
Comment 5 Jindrich Novy 2006-04-06 08:59:34 EDT
Hello Thorsten,

yes, it seems like a wrong component, sudo needs fixing to allow executing via
ssh. But I doubt that someone would like to implement such feature since
launching X applications via sudo isn't very convenient. Reassigning.
Comment 6 Thorsten Leemhuis 2006-04-08 13:21:19 EDT
Well, there are other distributions taht don't even allow root logins and do
everything ^w a lot though sudo. So the statement "launching X applications via
sudo isn't very convenient" is a bit irritating.

Well, I don't care as long as it get's fixed.

Comment 7 Jindrich Novy 2006-04-08 15:43:08 EDT
(In reply to comment #6)
> Well, there are other distributions taht don't even allow root logins and do
> everything ^w a lot though sudo. So the statement "launching X applications via
> sudo isn't very convenient" is a bit irritating.

To be more precise I meant launching X apps under Fedora via sudo isn't very
convenient (because of userhelper/consolehelper authentization design,
especially the system-config-* stuff).
Comment 8 Karel Zak 2006-04-09 15:42:34 EDT

*** This bug has been marked as a duplicate of 164671 ***

Note You need to log in before you can comment on or make changes to this bug.