Bug 142680 - alsa snd_ice1712
alsa snd_ice1712
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-12 11:31 EST by Eric Fox
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-06 08:50:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Fox 2004-12-12 11:31:55 EST
a fresh install of fc3 breaks alsa snd_ice1712 operability. the only
output i can get from the sound card is from xmms using oss drivers.
alsa works properly with a second card snd_ens1371.

-- soundcards

hw:0,0 maudio delta44
hw:1,0 creative sblive

-- lsmod

snd_ice1712            67081  7
snd_ice17xx_ak4xxx      4289  1 snd_ice1712
snd_pcm_oss            47608  1
snd_mixer_oss          17217  3 snd_pcm_oss
snd_pcm                97993  3 snd_ens1371,snd_ice1712,snd_pcm_oss
snd_timer              29765  1 snd_pcm
snd_page_alloc          9673  1 snd_pcm
snd_ak4xxx_adda         5441  2 snd_ice1712,snd_ice17xx_ak4xxx
snd_cs8427             10689  1 snd_ice1712
snd_ac97_codec         64401  2 snd_ens1371,snd_ice1712
snd_i2c                 5313  2 snd_ice1712,snd_cs8427
snd_mpu401_uart         8769  1 snd_ice1712
snd_rawmidi            26725  2 snd_ens1371,snd_mpu401_uart
snd_seq_device          8137  1 snd_rawmidi
snd                    54053  31
snd_ens1371,snd_ice1712,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_ak4xxx_adda,snd_cs8427,snd_ac97_codec,snd_i2c,snd_mpu401_uart,snd_rawmidi,snd_seq_device
soundcore               9889  4 snd


-- /etc/asound.conf

pcm.!default { type hw card 0 }
ctl.!default { type hw card 0 }

-- /etc/modprobe.conf
alias snd-card-0 snd-ice1712
options snd-card-0 index=0
install snd-ice1712 /sbin/modprobe --ignore-install snd-ice1712 &&
/usr/sbin/alsactl restore >/dev/null 2>&1 || :
remove snd-ice1712 { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; };
/sbin/modprobe -r --ignore-remove snd-ice1712alias snd-card-1 snd-ens1371
options snd-card-1 index=1
install snd-ens1371 /sbin/modprobe --ignore-install snd-ens1371 &&
/usr/sbin/alsactl restore >/dev/null 2>&1 || :
remove snd-ens1371 { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; };
/sbin/modprobe -r --ignore-remove snd-ens1371
Comment 1 Bill Nottingham 2004-12-13 20:41:50 EST
Do you get errors, or just no sound?

Is the proper device unmuted?
Comment 2 Eric Fox 2004-12-14 00:52:00 EST
yes, the proper device is unmuted.

only errors are in playback programs:

aplay -D hw:0,0 /usr/share/sounds/error.wav
Playing WAVE '/usr/share/sounds/error.wav' : Signed 16 bit Little
Endian, Rate 44100 Hz, Mono
aplay: set_params:854: Sample format non available

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: M44 [M Audio Delta 44], device 0: ICE1712 multi [ICE1712 multi]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: AudioPCI [Ensoniq AudioPCI], device 0: ES1371/1 [ES1371 DAC2/ADC]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: AudioPCI [Ensoniq AudioPCI], device 1: ES1371/2 [ES1371 DAC1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0


ll /dev/snd/pcmC*
crw-------  1 efox root 116, 24 Dec 13 13:09 /dev/snd/pcmC0D0c
crw-------  1 efox root 116, 16 Dec 13 13:09 /dev/snd/pcmC0D0p
crw-------  1 efox root 116, 56 Dec 13 13:09 /dev/snd/pcmC1D0c
crw-------  1 efox root 116, 48 Dec 13 13:09 /dev/snd/pcmC1D0p
crw-------  1 efox root 116, 49 Dec 13 13:09 /dev/snd/pcmC1D1p
Comment 3 Martin Stransky 2005-01-03 08:32:58 EST
You have to use "aplay -D plughw:0,0 /usr/share/sounds/error.wav"
instead, because your HW probably don't support Signed 16 bit Little
Endian 44100 Hz Mono waves directly. Do you have problem with any
other playback software, or only with aplay?
Comment 4 Eric Fox 2005-01-04 01:46:35 EST
thanks for the tip in the right direction martin. that worked! now to
get my audio apps to use plughw:0,0.

Note You need to log in before you can comment on or make changes to this bug.