This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 142687 - previously included patch for touch options "backward"/"forward" got dropped
previously included patch for touch options "backward"/"forward" got dropped
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-12 14:43 EST by Moritz Barsnick
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-13 04:39:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
original patch to add differential time (forward/backward) options to "touch" (4.83 KB, patch)
2004-12-12 14:45 EST, Moritz Barsnick
no flags Details | Diff
patch to add the same options to "touch" in coreutils (5.96 KB, patch)
2004-12-12 14:48 EST, Moritz Barsnick
no flags Details | Diff

  None (edit)
Description Moritz Barsnick 2004-12-12 14:43:13 EST
Description of problem:
Previously (perhaps only in fileutils, perhaps during coreutils times 
as well), there was a patch included which gave "touch" special 
options to set the date of a file back or forwards by a certain 
amount of seconds.

Version-Release number of selected component (if applicable):
5.2.1-34

How reproducible:
always

Steps to Reproduce:
1. touch --help | grep -E "\-(B|F)" 
  
Actual results:
(nothing)

Expected results:
  -B SEC, --backward=SEC date back SEC seconds
  -F SEC, --forward=SEC  date forward SEC seconds

Additional info:
I thought this patch was also available as a bugzilla attachment, but 
I can't find it. It was definitely originally from one of RedHat's 
SRC RPMs. Either fileutils or even ported to coreutils, as I said.

I'll attach the original and an updated version of the patch an beg 
you to reinclude it. It is very practical, e.g. if you borked 
something by having a wrong BIOS date.

I actually recommend you to submit this upstream. :) I have my doubts 
about the diff being given as int, but guess it's okay for a start. :
)
Comment 1 Moritz Barsnick 2004-12-12 14:45:25 EST
Created attachment 108410 [details]
original patch to add differential time (forward/backward) options to "touch"

This is as close to the patch originally provided by RedHat as it can be. This
is for reference, it doesn't apply to current coreutils. New patch will follow
below.
Comment 2 Moritz Barsnick 2004-12-12 14:48:11 EST
Created attachment 108411 [details]
patch to add the same options to "touch" in coreutils

This patch actually applies against coreutils-5.2.1. I had to ommit some
sections due to code change, but it still perfectly "works for me".
Comment 3 Tim Waugh 2004-12-13 04:39:03 EST
Dropped intentionally.  Use --date="+n seconds"/--date="-n seconds" instead.
Comment 4 Moritz Barsnick 2004-12-13 07:39:58 EST
Ah, thanks, I get the point!

"Relative items in date strings" was the info section I should have looked for.

Mea culpa and sorry for wasting your time,
Moritz

Note You need to log in before you can comment on or make changes to this bug.