Bug 14270 - S3 Savage4 Xserver goes haywire
S3 Savage4 Xserver goes haywire
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
6.2
i386 Linux
high Severity high
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-19 04:47 EDT by Richard Russell
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-14 12:41:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Russell 2000-07-19 04:47:12 EDT
Problem occurs when running the XF86_SVGA XServer (from either XFree86 or
downloaded from
ftp://ftp.diamondmm.com/pub/s3/desktop/395/395_xf86_1011.tar.gz), and
running Citrix Metaframe Client 3.00.97 connecting to a Windows NT4
machine, and running MS Outlook 97 or 98.

Clicking in Outlook message header pane scroll bar, to page down, will
reliably cause the XServer to draw pseudo-random XOR rectangles on the
screen, will cause X to use all available CPU, and will cause machine to be
inoperable. Console won't respond to anything, including Ctrl-Alt-Del,
Ctrl-Alt-Fn and Ctrl-Alt-[+|-|Bkspce] Only solution is to remotely log in
and kill the X process.

Also, in normal case (prior to causing X to malfunction as above), pressing
Ctrl-Alt-Fn to get to Virtual Terminal n while X is running will often
cause X to lock up. Screen re-syncs, but no virtual terminal is visible. X
remains on screen, but doesn't respond to mouse or keyboard. Again, only
solution is to remotely log in and kill X.

These happen regardless of whether the BIOS upgrade
(ftp://ftp.diamondmm.com/pub/s3/desktop/395/395_bios_2129.exe) has been
installed.

XServer startup:

[rrussell@localhost]~> startx            


XFree86 Version 3.3.6 / X Window System
(protocol Version 11, revision 0, vendor release 6300)
Release Date: January 8 2000
	If the server is older than 6-12 months, or if your card is newer
	than the above date, look for a newer version before reporting
	problems.  (see http://www.XFree86.Org/FAQ)
Operating System: Linux 2.2.5-22smp i686 [ELF] 
Configured drivers:
  SVGA: server for SVGA graphics adaptors (Patchlevel 1):
      s3_savage, NV1, STG2000, RIVA 128, RIVA TNT, RIVA TNT2,
      RIVA ULTRA TNT2, RIVA VANTA, RIVA ULTRA VANTA, RIVA INTEGRATED,
      GeForce 256, GeForce DDR, Quadro, ET4000, ET4000W32, ET4000W32i,
      ET4000W32i_rev_b, ET4000W32i_rev_c, ET4000W32p, ET4000W32p_rev_a,
      ET4000W32p_rev_b, ET4000W32p_rev_c, ET4000W32p_rev_d, ET6000, ET6100,
      et3000, pvga1, wd90c00, wd90c10, wd90c30, wd90c24, wd90c31, wd90c33,
      gvga, r128, ati, sis86c201, sis86c202, sis86c205, sis86c215,
      sis86c225, sis5597, sis5598, sis6326, sis530, sis620, sis300, sis630,
      sis540, tvga8200lx, tvga8800cs, tvga8900b, tvga8900c, tvga8900cl,
      tvga8900d, tvga9000, tvga9000i, tvga9100b, tvga9200cxr, tgui9400cxi,
      tgui9420, tgui9420dgi, tgui9430dgi, tgui9440agi, cyber9320, tgui9660,
      tgui9680, tgui9682, tgui9685, cyber9382, cyber9385, cyber9388,
      cyber9397, cyber9520, cyber9525, 3dimage975, 3dimage985,
cyber9397dvd,
      blade3d, cyberblade, clgd5420, clgd5422, clgd5424, clgd5426,
clgd5428,
      clgd5429, clgd5430, clgd5434, clgd5436, clgd5446, clgd5480, clgd5462,
      clgd5464, clgd5465, clgd6205, clgd6215, clgd6225, clgd6235, clgd7541,
      clgd7542, clgd7543, clgd7548, clgd7555, clgd7556, ncr77c22,
ncr77c22e,
      cpq_avga, mga2064w, mga1064sg, mga2164w, mga2164w AGP, mgag200,
      mgag100, mgag400, oti067, oti077, oti087, oti037c, al2101, ali2228,
      ali2301, ali2302, ali2308, ali2401, cl6410, cl6412, cl6420, cl6440,
      video7, ark1000vl, ark1000pv, ark2000pv, ark2000mt, mx, realtek,
      s3_virge, AP6422, AT24, AT3D, s3_svga, NM2070, NM2090, NM2093,
NM2097,
      NM2160, NM2200, ct65520, ct65525, ct65530, ct65535, ct65540, ct65545,
      ct65546, ct65548, ct65550, ct65554, ct65555, ct68554, ct69000,
      ct64200, ct64300, mediagx, V1000, V2100, V2200, p9100, spc8110, i740,
      i740_pci, Voodoo Banshee, Voodoo3, i810, i810-dc100, i810e, smi,
      generic
(using VT number 7)

XF86Config: /usr/X11R6/lib/X11/XF86Config
(**) stands for supplied, (--) stands for probed/default values
(**) XKB: keycodes: "xfree86"
(**) XKB: types: "default"
(**) XKB: compat: "default"
(**) XKB: symbols: "us(pc101)"
(**) XKB: geometry: "pc"
(**) XKB: rules: "xfree86"
(**) XKB: model: "pc101"
(**) XKB: layout: "us"
(**) Mouse: type: PS/2, device: /dev/mouse, buttons: 3
(**) SVGA: Graphics device ID: "S3 Inc.|Savage 4"
(**) SVGA: Monitor ID: "IBM 6556 P72"
(--) SVGA: Mode "1600x1200" needs hsync freq of 87.50 kHz. Deleted.
(--) SVGA: Mode "1152x864" needs hsync freq of 89.62 kHz. Deleted.
(--) SVGA: Mode "1280x1024" needs hsync freq of 91.15 kHz. Deleted.
(--) SVGA: Mode "1600x1200" needs hsync freq of 93.75 kHz. Deleted.
(--) SVGA: Mode "1600x1200" needs hsync freq of 105.77 kHz. Deleted.
(--) SVGA: Mode "1280x1024" needs hsync freq of 107.16 kHz. Deleted.
(--) SVGA: Mode "1800X1440" needs hsync freq of 96.15 kHz. Deleted.
(--) SVGA: Mode "1800X1440" needs hsync freq of 104.52 kHz. Deleted.
Warning: The directory "/usr/X11R6/lib/X11/fonts/TrueType" does not exist.
         Entry deleted from font path.
(**) FontPath set to "unix/:-1"
(--) SVGA: PCI: S3 Savage4 rev 3, Memory @ 0xfeb80000, 0xf0000000
(--) SVGA: SAVAGE: Savage4 rev 3, Linear FB @ 0xfeb80000
(--) SVGA: Detected S3 Savage4
(--) SVGA: using driver for chipset "s3_savage"
(--) SVGA: videoram:  16384k
(--) SVGA: Ramdac speed: 250 MHz  (220 MHz for 32 bpp)
(--) SVGA: Detected current MCLK value of 125.284 MHz
(--) SVGA: VBE Version 2.0
(--) SVGA: BIOS label is "S3 Incorporated. Savage4"
(--) SVGA: Found 13 modes at this depth:
[10f] 320 x 200, 70Hz
[134] 320 x 240, 72Hz
[144] 400 x 300, 72Hz
[154] 512 x 384, 70Hz
[11e] 640 x 400, 70Hz
[112] 640 x 480, 160Hz, 85Hz, 75Hz, 72Hz, 60Hz
[174] 720 x 480, 75Hz
[17f] 720 x 576, 75Hz
[115] 800 x 600, 160Hz, 85Hz, 75Hz, 72Hz, 60Hz, 56Hz
[118] 1024 x 768, 130Hz, 85Hz, 75Hz, 70Hz, 60Hz
[164] 1152 x 864, 100Hz, 85Hz, 75Hz, 70Hz, 60Hz
[11b] 1280 x 1024, 85Hz, 75Hz, 60Hz
[124] 1600 x 1200, 60Hz
(--) SVGA: chipset:  s3_savage
(--) SVGA: videoram: 16384k
(**) SVGA: Using 32 bpp, Depth 24, Color weight: 888
(--) SVGA: Maximum allowed dot-clock: 220.000 MHz
(--) SVGA: Interlace modes are not supported at 32 bpp
(--) SVGA: Interlace modes are not supported at 32 bpp
(--) SVGA: Interlace modes are not supported at 32 bpp
(**) SVGA: Mode "1280x1024": mode clock = 135.000
(--) SVGA: Virtual resolution set to 1280x1024
(--) SVGA: SpeedUp code selection modified because virtualX != 1024
(--) SVGA: s3_savage: Using hardware cursor
Chose mode 11b at 75Hz.
(--) SVGA: Using XAA (XFree86 Acceleration Architecture)
(--) SVGA: XAA: Solid filled rectangles
(--) SVGA: XAA: Screen-to-screen copy
(--) SVGA: XAA: 8x8 pattern fill
(--) SVGA: XAA: 8x8 color expand pattern fill
(--) SVGA: XAA: Using 10 128x128 areas for pixmap caching
(--) SVGA: XAA: Caching tiles and stipples
(--) SVGA: XAA: General lines and segments

I hope that is enough information...


Thanks for your prompt reply.

Richard Russell
Systems Administrator
Dept for Environment and Heritage,
South Australian Government
Comment 1 Preston Brown 2000-10-04 15:20:33 EDT
*** Bug 17991 has been marked as a duplicate of this bug. ***
Comment 2 Mike A. Harris 2001-03-06 12:42:39 EST
Please try the latest packages in my personal ftp space:
http://people.redhat.com/mharris/xfree86
4.0.2-11.4.0 as of this writing.  A totally new Savage driver is included
that fixes all known issues as far as I am aware.

Note You need to log in before you can comment on or make changes to this bug.