Bug 142706 - When Hangul Name is over 3 character, 4th character doesn't be seen in command line's directory name
When Hangul Name is over 3 character, 4th character doesn't be seen in comm...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mc (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-13 00:38 EST by sangu
Modified: 2013-07-02 19:03 EDT (History)
2 users (show)

See Also:
Fixed In Version: 4.6.1a-0.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-21 09:59:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sangu 2004-12-13 00:38:57 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ko-KR; rv:1.7.5)
Gecko/20041212 Firefox/1.0

Description of problem:
When Hangul Name is  over 3 charecter, 4th character doesn't be seen
in command line's directory name.

Hangul is Korean alphabet.



Version-Release number of selected component (if applicable):
mc-4.6.1a-0.1

How reproducible:
Always

Steps to Reproduce:
1. mkdir 일이삼사오
2. cd 일이삼사오
3. mc
    

Actual Results:  Directory name is "일이삼" in commandline.

Expected Results:  Directory name is "일이삼사오" in commandline.

Additional info:

lcoale is ko_KR.UTF-8
Comment 2 Jindrich Novy 2004-12-21 09:59:15 EST
Sangu, the problem was in the mbstrlen() in utf8 patch. I fixed it so
this problem should not occur any more. I addition I did several fixes
to the code, so that the wide text in ko_KR.UTF-8 locale will fit
pull-down menus and dialogs, so it makes a live with KR locales a bit
easier.

Could you please check if you see yet anything wrong with the
mentioned locales in mc?

Note You need to log in before you can comment on or make changes to this bug.