Bug 142720 - Unsupported ATIIXP IDE chipset
Summary: Unsupported ATIIXP IDE chipset
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Alan Cox
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-13 11:58 UTC by Enrico Scholz
Modified: 2007-11-30 22:10 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-05 07:10:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Enrico Scholz 2004-12-13 11:58:27 UTC
Description of problem:

The ATIIXP chipsets with ID 1002:4379 and 1002:4376 are unsupported by
the kernel. This causes PIO mode operation with horrible performance
and triggers bug #142713.

At least for the :4379 one, DMA seems to work without problems when
doing

| static struct pci_device_id atiixp_pci_tbl[] = {
|         { PCI_VENDOR_ID_ATI, PCI_DEVICE_ID_ATI_IXP_IDE, PCI_ANY_ID, PCI_ANY_ID, 0, 0, 0},
|+        { PCI_VENDOR_ID_ATI, PCI_DEVICE_ID_ATI_IXP_IDE+0x30, PCI_ANY_ID, PCI_ANY_ID, 0, 0, 0},
|         { 0, },
| };

in drivers/ide/pci/atiixp.c and inserting it as a separate module. I
could not test the :4376 one because I am unable to build the complete
kernel (build-failures on AMD64).



Version-Release number of selected component (if applicable):

kernel-2.6.9-1.681_FC3  (both i686 and x86_64)


How reproducible:

100%

Comment 1 Sitsofe Wheeler 2004-12-13 18:14:39 UTC
Sounds a bit like bug #142647 (although that is a different vendor id?)

Comment 2 Enrico Scholz 2004-12-17 10:35:30 UTC
Bug #142647 seems to be fixed upstream already. But 1002:437[69] are still
unsupported.

Comment 3 Enrico Scholz 2004-12-21 18:36:15 UTC
a trivial patch for 1002:4379 can be found at
http://marc.theaimsgroup.com/?l=linux-ide&m=110357606225070&w=2

this adds support for 1002:4376 also, but I see data-corruption on
CD-ROM drives. It will need further tests...

Comment 4 Dave Jones 2005-07-15 19:40:54 UTC
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.


Note You need to log in before you can comment on or make changes to this bug.