Bug 142774 - Ooops (hotplug) and kernel panic with kernel-2.6.9-1.714_FC3
Ooops (hotplug) and kernel panic with kernel-2.6.9-1.714_FC3
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-13 19:16 EST by Féliciano Matias
Modified: 2015-01-04 17:13 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-09 22:33:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Some Ooops (13.91 KB, text/plain)
2004-12-13 19:18 EST, Féliciano Matias
no flags Details

  None (edit)
Description Féliciano Matias 2004-12-13 19:16:36 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
kernel-2.6.9-1.714_FC3 from :
http://people.redhat.com/davej/kernels/Fedora/FC3/RPMS.kernel/

Ooops with the hotplug sub-system.


Also got one kernel panic.
Here is last lines (manual copy) :
kernel panic - not syncing: mm/map.c:1928:
spinlock(kernel/fork.c:da872534) already locked by mm/memory.c/1792
-----------
Another Ooops
-----------
<0> kernel panic - not syncing: Fatal exception in interrupt.



Version-Release number of selected component (if applicable):
kernel-2.6.9-1.714_FC3

How reproducible:
Sometimes

Additional info:

[root@one ~]# cat /proc/cpuinfo
processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 6
model           : 6
model name      : AMD Athlon(tm) XP 1600+
stepping        : 2
cpu MHz         : 1405.557
cache size      : 256 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca
cmov pat pse36 mmx fxsr sse syscall mp mmxext 3dnowext 3dnow
bogomips        : 2768.89

[root@one ~]# lspci
00:00.0 Host bridge: VIA Technologies, Inc. VT8366/A/7 [Apollo
KT266/A/333]
00:01.0 PCI bridge: VIA Technologies, Inc. VT8366/A/7 [Apollo
KT266/A/333 AGP]
00:05.0 Unknown mass storage controller: Triones Technologies, Inc.
HPT366/368/370/370A/372 (rev 03)
00:06.0 ATM network controller: STMicroelectronics ST70137 [Unicorn]
ADSL DMT Transceiver (rev 10)
00:08.0 Multimedia audio controller: Ensoniq ES1371 [AudioPCI-97] (rev 06)
00:09.0 Multimedia video controller: Brooktree Corporation Bt848 Video
Capture (rev 12)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8233 PCI to ISA Bridge
00:11.1 IDE interface: VIA Technologies, Inc.
VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:11.5 Multimedia audio controller: VIA Technologies, Inc.
VT8233/A/8235/8237 AC97 Audio Controller (rev 10)
01:00.0 VGA compatible controller: Matrox Graphics, Inc. MGA G400 AGP
(rev 04)
Comment 1 Féliciano Matias 2004-12-13 19:18:00 EST
Created attachment 108478 [details]
Some Ooops
Comment 2 Jim Cornette 2004-12-20 18:13:36 EST
Just adding information regarding the test kernel and panic states. I
got this condition when exiting the GUI. Sometimes the GUI would exit
and go into a continuous loop. Other times, the kernel would panic.

Also a note for the test kernels. This kernel tears to shreads the 815
video and also the -698 worked poorly and caused a slew of lockups on
this computer.

The error for the 815 graphics card is below.

Dec 20 18:26:43 cornette-fc3-hda kernel: [drm:i810_wait_ring] *ERROR*
lockup
Dec 20 18:27:13 cornette-fc3-hda kernel: [drm:i810_wait_ring] *ERROR*
lockup
Dec 20 18:27:13 cornette-fc3-hda kernel: [drm:i810_wait_ring] *ERROR*
lockup

I am currently running 2.6.9-1.681_FC3 on both systems without any
problems. I backed out of testing because of the extreme instability
that the kernel exhibits on these two machines. On a newer computer,
it seems to work fine with this test kernel.

Comment 3 Russell Tokuyama 2004-12-23 17:05:17 EST
I have the same problem on an IBM ThinkPad A22p running
2.6.9-1.9_FC2/i686.  The kernel panics when doing a shutdown to turn
off the laptop.  This is what I copied from the screen:

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
EFLAGS: 00010282  (2.6.9-1.9_FC2)
EIP is at handle_mm_fault+0xbb/0x1fe
eax: d24effb0  ebx: d6f9f780  ecx: d24effb0  edx: fffff000
esi: b7fec928  edi: d13a6b7c  ebp: ce7bb5c48  esp: cc538ea0
di: 0078  es: 007b  ss: 0068
                                                                     
          
Process hotplug (pid: 3284), threadinfo=d3ce7000 task=d3cef1b0)
Stack: ...
CalTrace:
  [<c0119464>] do_page_fault+0x1a5/0x4c3
  [<c01192bf>] do_page_fault+0x0/0x4c3
  [<c0306c37>] do_page_fault+0x2f/0x38
  [<c011b543>] do_page_fault+0x4f/0x55
  [<c03069d2>] do_page_fault+0x6/0x14
Code: ...
<6>Note: hotplug [3284] exited with preempt_count 1
                                                                     
          
Kernel panic - not syncing: mm/mmap.c: 1928 spin_lock (kernel/fork.c:
d6f9f7d4 already locked by mm/memory.c/1792)
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Other data points:

2.6.9-1.6_FC2/i686 doesn't panic when shutting down but can't HotSync
my Handspring Visor PDA via the USB port.

Both, 2.6.9-1.6_FC2 and 2.6.9-1.9_FC2 hang at acpi_power_off.  I don't
believe 2.6.8-1.521 hung when shutting down.
Comment 4 Féliciano Matias 2005-01-03 04:19:04 EST
2.6.9-1.722_FC3 ( from
http://people.redhat.com/davej/kernels/Fedora/FC3/ ) works fine.

Time to close the bug ?
Comment 5 Féliciano Matias 2005-01-09 22:33:01 EST
Bug fixed. Bug closed.

Note You need to log in before you can comment on or make changes to this bug.