Bug 142808 - When the automatic spelling checker is launched from a right click it causes the machine to start swapping uncontrollably
When the automatic spelling checker is launched from a right click it causes ...
Status: CLOSED DUPLICATE of bug 124374
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
Depends On:
  Show dependency treegraph
Reported: 2004-12-14 06:30 EST by Xander D Harkness
Modified: 2016-06-07 18:45 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-12-15 11:05:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Xander D Harkness 2004-12-14 06:30:18 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.3; Linux) (KHTML, like Gecko)

Description of problem:
I launch openoffice.org while running only windowmaker or KDE desktop. Open a document, right click on a red wavy line demonstrating a spelling error.

On previous versions, Openoffice.org took maybe 40 seconds and a lot of disk thrashing to open the spelling options (40 seconds on a fast machine is far too long, abiword manages this in less than a second)

The current version of Openoffice.org causes the disk to start thrashing uncontrollably, I have a cron job that runs every minute to do a dump of top, so I could see what processes were using what memory.  The disk thrashing is so bad that the cron job does not succeed in delivering any output and I am unable to do anything other than turn the machine off with the power button.

The hardware is a X31 IBM laptop with 256Mb RAM, and a 1400MHz processor.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Open Openoffice.org and type a sentence with a typographical error. Ensure that automatic spell checking is turned on.
2. Right click on a mis-spelled word.
3. The computer's disk starts thrashing, the spelling checker alternatives never appear and the machine must be rebooted.

Actual Results:  The machine swaps uncontrollably and I am unable to kill the process in the GUI or login via a virtual console.

Expected Results:  The spell checker should quickly provide a list of words with similar but correct spellings.

Additional info:
Comment 1 Sitsofe Wheeler 2004-12-14 18:31:10 EST
This is a dup of bug #124374
Comment 2 Caolan McNamara 2004-12-15 11:03:04 EST

*** This bug has been marked as a duplicate of 124374 ***

Note You need to log in before you can comment on or make changes to this bug.