Bug 142813 - nfsv4 kernel error on fedora 3: xdr error 10008
nfsv4 kernel error on fedora 3: xdr error 10008
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
Ben Levenson
:
Depends On:
Blocks: 165064
  Show dependency treegraph
 
Reported: 2004-12-14 08:38 EST by Steve Dickson
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version: 1.0.6-50
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-05 03:33:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Proposed Patch (658 bytes, patch)
2004-12-14 08:57 EST, Steve Dickson
no flags Details | Diff

  None (edit)
Description Steve Dickson 2004-12-14 08:38:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020

Description of problem:
when trying to mount a nfs4 filesystem on another remote fedora core 3
(FC3), i got the following error repeated on the client syslog :
Dec 10 15:46:27 filer2 kernel: decode_getfattr: xdr error 10008!
Dec 10 15:46:43 filer2 kernel: decode_getfattr: xdr error 10008!

... while the mount command seems to be "freezed" (but interruptible
by ^C). So any of my attempts to mount with nfs4 failed.

Here is the config on both nodes:
kernel 2.6.9 compiled from tarballs from kernel.org, all nfs option
compiled-in the kernel itself.
Fedora Core 3 with unmodified tools (FC3 seems to natively support nfs4)
both portmaps on client and server listen only to localhost
(vanemery's doc allow access to portmap only to localhost, so i think
it does the same)

Server: nfs export of a XFS partition
$ cat /etc/exports
/vol/0/nfsroot  10.0.0.0/24(ro,fsid=0,insecure,no_subtree_check,sync)

The mount command on the client was:
mount -t nfs4 -o ro,intr 10.0.0.58:/ /home/

i used the AUTH_SYS method described step by step on the vanemery tutorial
(http://www.vanemery.com/Linux/NFSv4/NFSv4-no-rpcsec.html)
except the "acl" mount option because xfs doesn't accept it. (i think
xfs supports ACLs natively)

anyone has an idea about the "xdr error 10008" error ?

Thanks in advance, 

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1.Mount an nfsv4 filesystem
2.
3.
    

Additional info:
Comment 1 Steve Dickson 2004-12-14 08:57:45 EST
Created attachment 108515 [details]
Proposed Patch

An if statement was removed that may been the
reason an event was not being register, which
in turned cause idmapper to ignore requests
from the kernel.
Comment 2 Steve Dickson 2005-02-14 13:26:24 EST
Fixed in nfs-utils-1.0.6-50.i386.rpm
Comment 3 W. Michael Petullo 2005-03-23 13:32:32 EST
Yes, this seems fixed.  Can someone confirm this and close the bug?
Comment 4 Rahul Sundaram 2005-09-05 03:33:38 EDT
Looks good to me. closing

Note You need to log in before you can comment on or make changes to this bug.