Bug 142890 - RHEL3: [PATCH] Missing AppleTalk ioctl for the 32bit/64bit mapping
RHEL3: [PATCH] Missing AppleTalk ioctl for the 32bit/64bit mapping
Status: CLOSED DUPLICATE of bug 140930
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: dff
Kernel
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-14 17:06 EST by Suzanne Hillman
Modified: 2007-11-30 17:07 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-06 19:32:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Suzanne Hillman 2004-12-14 17:06:56 EST
*** This bug has been split off bug 140930 ***

Description of problem:
Missing AppleTalk ioctl for the 32bit/64bit mapping
The patch (at end) will fix the missing AppleTalk kernel ioctls for the 32 API
into 64Bit API translation.

We need the AppleTalk networking for our EtherShare product. It would be 
good if the "appletalk" module gets included by default instead of 
building the kernel manually with the appletalk option enabled.

It would be great if somebody can confirm that the patches are getting 
integrated.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
2) ---- /usr/src/linux-2.4/arch/x86_64/ia32/ia32_ioctl.c -----
--- ia32_ioctl.c.SAVE   2004-11-26 11:51:31.000000000 +0100
+++ ia32_ioctl.c        2004-11-26 11:59:25.000000000 +0100
@@ -61,6 +61,7 @@
  #include <linux/ctype.h>
  #include <net/bluetooth/bluetooth.h>
  #include <net/bluetooth/rfcomm.h>
+#include <linux/atalk.h>
  #if defined(CONFIG_BLK_DEV_LVM) || defined(CONFIG_BLK_DEV_LVM_MODULE)
  /* Ugh. This header really is not clean */
  #define min min
@@ -4251,6 +4252,13 @@
  HANDLE_IOCTL(SIOCSIFMAP, dev_ifsioc)
  HANDLE_IOCTL(SIOCGIFADDR, dev_ifsioc)
  HANDLE_IOCTL(SIOCSIFADDR, dev_ifsioc)
+
+/* ioctls used by appletalk ddp.c */
+HANDLE_IOCTL(SIOCATALKDIFADDR, dev_ifsioc)
+HANDLE_IOCTL(SIOCDIFADDR, dev_ifsioc)
+HANDLE_IOCTL(SIOCSARP, dev_ifsioc)
+HANDLE_IOCTL(SIOCDARP, dev_ifsioc)
+
  HANDLE_IOCTL(SIOCGIFBRDADDR, dev_ifsioc)
  HANDLE_IOCTL(SIOCSIFBRDADDR, dev_ifsioc)
  HANDLE_IOCTL(SIOCGIFDSTADDR, dev_ifsioc)

------- Additional comment by Ernie Petrides on 2004.11.30 16:36 -------

This is a feature request.  Appletalk is currently unsupported.

------- Additional comment by Helmut Tschemernjak on 2004.12.01 07:54 -------

We need the AppleTalk for six turnkey products running on RedHat ES/AS 3, we
have about 1300 Linux based server installations. Please fix this bug and and
include AppleTalk protocol as a module by default in the next version.

The same patch is already in the kernel 2.6.9+patches (done by me posted via
Andy Kleen).
Comment 1 Ernie Petrides 2005-10-06 19:32:08 EDT
Converting back to a bugzilla and closing as dup of what it was created from.

*** This bug has been marked as a duplicate of 140930 ***

Note You need to log in before you can comment on or make changes to this bug.