Bug 142976 - RHEL 3.0 v2.4.21-20.0.1.EL kernel panics after several hours of running raw I/O
RHEL 3.0 v2.4.21-20.0.1.EL kernel panics after several hours of running raw I/O
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Larry Woodman
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-15 10:44 EST by Heather Conway
Modified: 2007-11-30 17:07 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:11:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
trace of Oops without PowerPath running on the system (26.50 KB, text/plain)
2004-12-15 10:46 EST, Heather Conway
no flags Details
trace of the Oops that occurred with PowerPath (34.00 KB, text/plain)
2004-12-15 10:49 EST, Heather Conway
no flags Details
Oops with no PP in text format (2.36 KB, text/plain)
2005-01-28 15:29 EST, Heather Conway
no flags Details
Oops with PP in text format (6.04 KB, text/plain)
2005-01-28 15:32 EST, Heather Conway
no flags Details

  None (edit)
Description Heather Conway 2004-12-15 10:44:42 EST
Description of problem:
On an Opteron based system, the RHEL 3.0 v2.4.21-20.0.1.EL kernel 
panics after several hours of running raw I/O.  This panic occurs 
both with and without PowerPath.  Per the PowerPath team:
One of the dd processes issues an IO and calls kiobuf_wait_for_io(), 
which in turn calls schedule(). In schedule(), the kernel attempts to 
perform a context switch, an panics because the task struct pointer 
passed in for the new process is NULL. This points to kernel memory 
corruption, more specifically corruption of CPU runqueueus.

Version-Release number of selected component (if applicable):
kernel-source-2.4.21-20.0.1.EL x86_64

How reproducible:
Run raw I/O for serveral hours on an AMD64 Opteron-based system

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Heather Conway 2004-12-15 10:46:01 EST
Created attachment 108621 [details]
trace of Oops without PowerPath running on the system

Enclosing a trace of the Oops that occurred without PowerPath running on the
system.
Comment 2 Heather Conway 2004-12-15 10:49:23 EST
Created attachment 108623 [details]
trace of the Oops that occurred with PowerPath 

Enclosing a trace of the Oops that occurred without PowerPath running on the
system.
Comment 3 Heather Conway 2004-12-15 10:49:54 EST
I neglected to mention that this is PowerPath v4.3.1.
Comment 4 Ernie Petrides 2004-12-15 18:04:07 EST
Heather, please attach a trace (oops output) from a non-tainted kernel.
Also, please do not attach Microsoft Word documents in the future.
Comment 5 Heather Conway 2005-01-28 09:32:02 EST
I have not been able to replicate this and have not received any 
feedback from the PowerPath team so I am considering this issue as 
NOTABUG.
Comment 6 Heather Conway 2005-01-28 15:29:30 EST
Created attachment 110369 [details]
Oops with no PP in text format
Comment 7 Heather Conway 2005-01-28 15:30:39 EST
oops - I closed the wrong Bugzilla.  The Oops output is being 
attached in text format.
Comment 8 Heather Conway 2005-01-28 15:32:05 EST
Created attachment 110370 [details]
Oops with PP in text format

Attaching text document of Oops with PowerPath installed.
Comment 9 AJ Johnson 2005-04-29 20:00:52 EDT
I am seeing a very similar issue, but the system doesn't panic.  What is the
status of this bug?
Comment 13 Larry Woodman 2005-09-16 10:36:39 EDT
Is this still a problem with the patest RHEL3-U6 update?  The reason I ask is
that several generic kernel changes and changes to the x86_64 specific code have
been made to RHEL3 since 2.1.21-20.  Can someone please verify that this problem
still occurs with the latest kernel?

Thanks, Larry Woodman
Comment 15 RHEL Product and Program Management 2007-10-19 15:11:13 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.