Bug 142983 - system-config-services fails to start
system-config-services fails to start
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: system-config-services (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nils Philippsen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-15 11:18 EST by Paul Hart
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-11 12:20:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
results of ls -l /etc/init.d/ (6.43 KB, text/plain)
2004-12-17 08:56 EST, Paul Hart
no flags Details
results of ls -l /etc/rc?.d/ (58.40 KB, text/plain)
2004-12-17 08:57 EST, Paul Hart
no flags Details
results of strace -Ff -s 160 -o /tmp/system-config-services.out /usr/sbin/system-config-services (1.60 MB, text/plain)
2004-12-30 12:13 EST, Paul Hart
no flags Details

  None (edit)
Description Paul Hart 2004-12-15 11:18:42 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
running system-config-services from a terminal crashes and gives this
error:

/usr/local/sbin/system-config-services:197: DeprecationWarning:
  self.btnStart = self.tbrSave.append_item(_("Start"), _("Start"),
None, icon, self.on_btnStart_clicked, None)
/usr/local/sbin/system-config-services:201: DeprecationWarning:
  self.btnStop = self.tbrSave.append_item(_("Stop"), _("Stop"), None,
icon, self.on_btnStop_clicked, None)
/usr/local/sbin/system-config-services:205: DeprecationWarning:
  self.btnRestart = self.tbrSave.append_item(_("Restart"),
_("Restart"), None, icon, self.on_btnRestart_clicked, None)
/usr/local/sbin/system-config-services:207: DeprecationWarning:
  self.tbrSave.insert_space(3)
/usr/local/sbin/system-config-services:211: DeprecationWarning:
  self.btnSave = self.tbrSave.append_item(_("_Save"), _("Save"), None,
icon, self.on_mnuSave_clicked, None)
/usr/local/sbin/system-config-services:216: DeprecationWarning:
  self.btnRevert = self.tbrSave.append_item(_("_Revert"), _("Revert"),
None, icon, self.on_mnuRevert_clicked, None)
/etc/init.d/f [Errno 2] No such file or directory: '/etc/init.d/f'
Traceback (most recent call last):
  File "/usr/local/sbin/system-config-services", line 683, in ?
    main()
  File "/usr/local/sbin/system-config-services", line 667, in main
    Gui()
  File "/usr/local/sbin/system-config-services", line 254, in __init__
    self.populateList()
  File "/usr/local/sbin/system-config-services", line 324, in populateList
    self.clstServices.append_row((servicename, ""),
int(self.dict_services[servicename][0][int(self.editing_runlevel)]))
IndexError: list index out of range



Version-Release number of selected component (if applicable):
system-config-services-0.8.16-1

How reproducible:
Always

Steps to Reproduce:
1. open a root terminal
2. run system-config-services
3.
    

Actual Results:  The GUI starts to display and then crashes and
disappears.

Expected Results:  The GUI should start and allow editing of servives.

Additional info:
Comment 1 Nils Philippsen 2004-12-17 05:30:38 EST
What do the following commands give?

ls -l /etc/init.d/
ls -l /etc/rc?.d/
Comment 2 Paul Hart 2004-12-17 08:56:49 EST
Created attachment 108791 [details]
results of ls -l /etc/init.d/
Comment 3 Paul Hart 2004-12-17 08:57:47 EST
Created attachment 108792 [details]
results of ls -l /etc/rc?.d/
Comment 4 Paul Hart 2004-12-17 08:58:59 EST
The results have been added as attachments.
Comment 5 Nils Philippsen 2004-12-30 11:08:07 EST
Hmm, system-config-services-0.8.16-1 is in Rawhide and not expected to work on
FC3 -- can you reproduce the problem with either 0.8.15-1 on FC3 or 0.8.16-1 on
Rawhide?
Comment 6 Nils Philippsen 2004-12-30 11:10:21 EST
If you can reproduce it, please run (one line)

strace -Ff -s 160 -o /tmp/system-config-services.out
/usr/sbin/system-config-services

as root and attach the resulting file "/tmp/system-config-services.out".
Comment 7 Paul Hart 2004-12-30 12:13:43 EST
Created attachment 109193 [details]
results of strace -Ff -s 160 -o /tmp/system-config-services.out /usr/sbin/system-config-services

I removed 0.8.16-1 and installed 0.8.15-1. The results are for FC3 with
the 0.8.15-1. I had gone to 0.8.16-1 in hopes it would fix the problem.
This is reproduceable and has been since day one.
Comment 8 Nils Philippsen 2005-01-04 08:52:47 EST
I think I'm getting somewhere, the problem you have (and I don't ;-) seems to be
related to this file in /etc/init.d:

lrwxrwxrwx  1 root root    37 Oct 21 12:43 avfbackground ->
/usr/local/sitescape/avfbackground.sh

This is a dangling symbolic link (i.e. the target doesn't exist), chkconfig
gives an error message and system-config-services throws the traceback above.
Don't remove the file right now -- I want you to test it when I've come up with
a fix.
Comment 9 Nils Philippsen 2005-01-04 12:06:38 EST
Fixed in CVS. The quick fix is throwing away stderr when running subcommands in
getstatusoutput(), stderr doesn't seem to be needed anywhere else.

Later/ideally the code grepping through chkconfig output should do at least
cursory checking whether the output is in the expected format and give warnings
if not.
Comment 10 Nils Philippsen 2005-01-11 08:41:16 EST
Should be fixed in system-config-services-0.8.17-0.fc3.1, pleasy verify.
Comment 11 Paul Hart 2005-01-11 10:29:06 EST
The bug has been fixed. Close this one and thanks.
Comment 12 Nils Philippsen 2005-01-11 12:20:23 EST
You can remove the dangling symlink now. Thanks for your report.

Note You need to log in before you can comment on or make changes to this bug.