Bug 143024 - pvmove does not autoload dm_mirror module
pvmove does not autoload dm_mirror module
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: initscripts (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-15 15:23 EST by Milan Kerslager
Modified: 2014-03-16 22:51 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-21 16:44:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Kerslager 2004-12-15 15:23:07 EST
When trying to use pvmove on fully updated RHEL4 Beta2 I've got  this
error message (lvm2-2.00.25-1.01):

Required device-mapper target(s) not detected in your kernel

This could be avoided by loading module dm_mirror by hand.

To fix: pvmove should autoload dm_mirror automagically
Comment 1 Alasdair Kergon 2004-12-15 15:52:51 EST
Initscripts are supposed to load all dm modules if LVM is in use - 
can you work out why they haven't?  Are any device-mapper modules 
loaded?

Is / on lvm or not and does that make a difference?

Autoloading will be dealt with upstream sometime, but needs interface 
enhancements.
Comment 2 Milan Kerslager 2004-12-15 16:47:16 EST
The system is fresh RHEL4b2. LVM is auto mounted datastore (originally
LVM1) to /home (so no / on LVM - I'm using RAID1 for root FS). No dm*
modules are loaded when system starts and the LVM is started and
mounted when system boots. I'm using LABEL in fstab and I run
vgconvert to convert LVM1 to LVM2:

vgconvert VGNAME

I have device-mapper in /proc/devices.

I see that rc.sysinit is trying to load dm-mod, but I have dm_mod in
output of lsmod and dm-mod.ko on the disc. Strange :)
Comment 3 Milan Kerslager 2004-12-15 16:51:02 EST
Well. dm_mod is autoloaded when system boots. But not dm_mirror which
is required by pvmove. Sorry for confusion.

So it seems that initscripts should be fixed or so.
Comment 4 Bill Nottingham 2004-12-22 18:03:09 EST
> Initscripts are supposed to load all dm modules if LVM is in use

That's the first I've heard of it. Why isn't it loaded on demand?
Comment 5 Bill Nottingham 2005-09-21 16:44:21 EDT
Closing this bug, due to response of the initial question.

Realistically, without any way to know what dm modules are needed, there's no
way to autoload.

Note that later releases, dm-mirror may be loaded before starting dmraid.

Note You need to log in before you can comment on or make changes to this bug.