This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 143064 - Obsoleted (or legacy) rpm tags in spec files should be replaced
Obsoleted (or legacy) rpm tags in spec files should be replaced
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Elliot Lee
Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-16 04:03 EST by Robert Scheck
Modified: 2014-03-16 22:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-12 08:32:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2004-12-16 04:03:45 EST
Description of problem:
Many Red Hat spec files contain obsoleted and/or legacy rpm tags, 
which should be replaced before the upgrade of RPM to 4.4.x - it 
will come, I guess (sooner or later).
  
Actual results / Expected results:
For most things,

  's/^Copyright:/License:/'
  's/^Serial:/Epoch:/'

over all spec files should do this for example. 

The tag 'RHNPlatform' will be obsoleted. More information about the
changes of RPM are in the RPM changelog. 

Additional info:
I assigned it to the distribution, because it maybe should done 
generally and not only per package.
Comment 1 Bill Nottingham 2004-12-16 09:36:17 EST
Assigning to CVS-meisters, if they want to do a search and replace...
Comment 2 Elliot Lee 2005-01-03 17:42:26 EST
About as low a priority as it gets, but I'll leave the bug open so we
know it's a potential issue.
Comment 3 Robert Scheck 2005-06-12 08:32:13 EDT
Time to close this bug now; Rawhide should be rebuilt completely for Fedora Core 
4 using rpm 4.4.1.

Note You need to log in before you can comment on or make changes to this bug.