Bug 143078 - XEN is broken by kernel patches 1950 &| 1951 for AGPGART
XEN is broken by kernel patches 1950 &| 1951 for AGPGART
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
: 142979 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-16 07:38 EST by taj
Modified: 2015-01-04 17:14 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-11 01:24:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Current Status (153.94 KB, image/png)
2004-12-17 12:26 EST, taj
no flags Details

  None (edit)
Description taj 2004-12-16 07:38:59 EST
This bug is going to take a while to fix so I'm taking the chance to
correct the typos in bug #142979 and marking it a dupicate of this.

-----------------

Regular suspects:

Patch1950: linux-2.6.9-agp-missing-cacheflushes.patch
Patch1951: linux-2.6.9-agp-posting-bugs.patch
kernel-xen0-2.6.9-1.1021_FC4 = last known good.
kernel-xen0-2.6.9-1.1032_FC4 = first known bad.

-----------------

Summary:

upgrading from kernel 1021 to 1032 broke Xen (even more).  System hard
locks after agpgart message.  Previous versions could run ttylinux. 
The current version does not boot.

Removing patch #1951 did not resolve the problem but removing #1951
and #1950 did resolve the problem.  #1951 does not apply clean without
#1950 and was not tested on its own.

-----------------

Machine:

440BX/ZX/DX - 82443BX/ZX/DX host bridge
82371 AG/DB/MB  chipset.
NM2360 video.
IBM 600X Thinkpad with 500 Mhz pII

-----------------

Diagnostics:

There is no functional serial port on this machine due to buggy BIOS
but the last messages with kernel build 1032 Xen0 as delivered are:

agpgart:  Detected an Intel 440BX Chipset.
agpgart:  Maximum main memory to use for agp memory:  96M
_
*hard lock*

-----------------

Expected:

Kernel build 1021 continues with:

agpgart:  Detected an Intel 440BX Chipset.
agpgart:  Maximum main memory to use for agp memory:  96M
agpgart: unable to get memory for graphics translation table
agpgart: agp_backend_initialize() failed.
agpgart-intel:  probe of 0000:00:00.0 failed with error -12

The boot completes and the system is usable on console.

-----------------

Informational:

Native 1021 and 1032 kernels have the following messages during boot:

Linux agpgart interface v0.100 (c) Dave Jones
agpgart:  Detected an Intel 440BX Chipset.
agpgart:  Maximum main memory to use for agp memory:  501M
agpgart:  AGP aperture is 64M @ 0x40000000

-----------------

Conclusion:

Removing patches #1950 and #1951 from 1032 returns xen0 to a usable
state as observed with build 1021.
Comment 1 taj 2004-12-16 07:41:13 EST
*** Bug 142979 has been marked as a duplicate of this bug. ***
Comment 2 taj 2004-12-17 10:21:08 EST
Build 1037 now boots with init=/bin/sh

Xen0 is locking (mostly) and oopsing (once) during init.  I'll try to
get more info.

Kernel build 1037:

agpgart:  Detected an Intel 440BX Chipset.
agpgart:  Maximum main memory to use for agp memory:  96M
agpgart: unable to get memory for graphics translation table
agpgart: agp_backend_initialize() failed.
agpgart-intel:  probe of 0000:00:00.0 failed with error -12

Linux (none) 2.6.9-1.1037_FC4xen0 #1 Fri Dec 17 00:02:16 EST 2004 i686
i686 i386 GNU/Linux
Comment 3 taj 2004-12-17 12:26:27 EST
Created attachment 108812 [details]
Current Status


This xen0 kernel isnt very reproducable.  It even boots sometimes.  I'll try
the next one.
Comment 4 taj 2004-12-17 19:59:45 EST

I should probably note that I lost the superblock on the native
filesystem with 2.6.9-1.1037_FC4xen0 once.
Comment 5 Dave Jones 2005-01-10 23:28:23 EST
should be fixed in current tree.
Comment 6 taj 2005-01-11 01:24:10 EST
2.6.10_1075_FC4

Indeed it appears to be fixed.  I'm no longer reproducing this specific bug.

...
Linux agpgart interface v0.100 (c) Dave Jones
agpgart:  Detected an Intel 440BX Chipset.
agpgart:  Maximum main memory to use for agp memory:  96M
agpgart: unable to get memory for graphics translation table
agpgart: agp_backend_initialize() failed.
agpgart-intel:  probe of 0000:00:00.0 failed with error -12
[drm] Initialized drm 1.0.0 20040925
...

Marking this RAWHIDE.
Comment 7 Alexander Boström 2005-02-05 09:23:27 EST
Hmm, that attachment doesn't seem to be relevant...
Comment 8 Alexander Boström 2005-02-05 09:26:15 EST
See also bug #147258.
Comment 9 taj 2005-02-05 14:35:08 EST

I stopped testing fc-devel Xen after 3 filesystem corruptions as mentioned in
comment 4.  I then posted the "no beer" image.   When agpgart isn't working
right it can just scribble info here and there and there and there so take care.
 Or better yet, make backups.

Note You need to log in before you can comment on or make changes to this bug.