Bug 143109 - CORE test continues even when SRPM not found
CORE test continues even when SRPM not found
Status: CLOSED WONTFIX
Product: Red Hat Ready Certification Tests
Classification: Retired
Component: other (Show other bugs)
2
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Rob Landry
Rob Landry
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-16 11:08 EST by Glen A. Foster
Modified: 2007-04-18 13:17 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-14 13:46:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Glen A. Foster 2004-12-16 11:08:02 EST
Description of problem: Maybe this is an error, maybe it's more of an
enhancement request.  In my haste to run some RHEL4 cert-suite tests
today I forgot to specify the SRPM variable in /etc/rhr/tests.conf and
then ran the CORE test.

Problem is that without the SRPM in place, there's simply no way the
CORE test can pass.  I think it makes sense for the CORE test to
stop-and-puke when SRPM is not found.

Version-Release number of selected component (if applicable):
# rpm -q rhr-rhel4
rhr2-rhel4-0.9-14.9i

How reproducible: 100%

Steps to Reproduce:
1. install/configure RHEL4 cert suite
2. do NOT configure SRPM
3. run the CORE test
  
Actual results:

Cleaning scratch space (/tmp/rhr).
Checking/configuring environment...
 CORE...
WARNING: SRPM not found

WARNING: required space may not be available on /tmp/rhr

Prep stage completed.
Press return to continue or control-c to quit

System Hardware Info Gathering...
 INFO...
 CORE...
Hardware Info stage compelted.
Press return to continue or control-c to quit

Starting interactive mode...
Interactive stage completed.
Starting automated test(s)...
 INFO...
 CORE...
WARNING: RPM build failed
Comment 1 Rob Landry 2004-12-16 11:17:39 EST
> I think it makes sense for the CORE test to stop-and-puke when SRPM
is not found.

It in fact does...

> Cleaning scratch space (/tmp/rhr).
> Checking/configuring environment...
>  CORE...
> WARNING: SRPM not found
  ^^^ PUKE ^^^
> 
> WARNING: required space may not be available on /tmp/rhr
> 
> Prep stage completed.
> Press return to continue or control-c to quit
  ^^^ STOP ^^^

...though perhaps that's puking then stopping :)  It doesn't kill off
the run since for some tests you could fix the above error at this
point (eg. put a floppy into the drive) or perhaps you don't care
about that specific test this time.
Comment 2 Glen A. Foster 2004-12-16 11:21:38 EST
Hrm.  Well, the CORE test is pretty essential for every run.  My
advice (or preference) is to have the entire run *stop* since it's a
fact that a missing SRPM value/file will invalidate the CORE test. 
It's the longest-running test (I think, I haven't made it all the way
through the RHEL4 suite) and this is both a time-saver and a good
check of dependencies.  IMO, of course :)
Comment 3 Rob Landry 2004-12-16 11:25:47 EST
Certainly willing to consider it; though if the SRPM isn't found the
test should be short.  As well; if needed CORE can be run later, AFAIK
there is no requirement for CORE with this NETWORK test.

/me is looking for convincing to do the work ;)
Comment 4 Glen A. Foster 2004-12-16 11:41:01 EST
Since INFO seems to be run every time another test is executed, it
might make more sense to have CORE abort the entire run so there's not
much confusion.

I'm thinking of the post-cert folks who will have to process all of
this  in addition to the overall 'usage model'.

It's up to you.  If it's not worth working on, close it WONTFIX and I
won't be offended, but I wanted to offer the report/idea.  FWIW.
Comment 5 Rob Landry 2005-04-14 13:46:42 EDT
I'm going to go ahead and close this WONTFIX; the website will take partial
results so a failed core doesn't invalidate the remaining of the tests.  As
well, ispec should copy the SRPMs for you.  When in manual mode, one can
<Ctrl>+<C> thier way out (either at the stopgap or during), so I think this is
covered well enough.

Note You need to log in before you can comment on or make changes to this bug.