Bug 14316 - guname doesn't find mailx
guname doesn't find mailx
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gnome-utils (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-20 12:03 EDT by Michael Redinger
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-04 22:49:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Redinger 2000-07-20 12:03:24 EDT
Selecting "Email Information" produces the error message
Application "guname" (process 2652) has crashed
due to fatal error.
(Segmentation fault)
Comment 1 Kjartan Maraas 2000-07-21 17:49:43 EDT
I can't reproduce it here with the latest gnome-utils from CVS. I get a failure
saying it can't execute the command 'mailx -s "System information for
localhost.localdomain" user@foo.org'

Either change guname to look for both, or add a symlink to mailx in the mailx
package.
(Seeing as it is named mailx that would probably be the right thing to do :)

Kjartan Maraas
Comment 2 Michael Redinger 2000-08-01 11:05:26 EDT
the segfault doesn't happen anymore since beta 4.
The mailx problem is still there.
Changing the title to reflect this changes.
Comment 3 Alan Cox 2000-08-04 22:05:23 EDT
It should be running the command as 'mail' not 'mailx' on Red Hat
Someone left a Debianism in I think 8)
Comment 4 Havoc Pennington 2000-08-04 22:49:33 EDT
Yes I originally implemented this tool on Debian, thus "mailx" - easy to fix,
as soon as I get through the MUST-FIX list
Comment 5 Havoc Pennington 2000-08-06 01:13:32 EDT
Fixed

Note You need to log in before you can comment on or make changes to this bug.