Bug 143179 - [punjabi] Cons+Virama+Ya should be post-base Ya
[punjabi] Cons+Virama+Ya should be post-base Ya
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: fonts-indic (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rahul Bhalerao
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-16 21:56 EST by Sukhjinder Sidhu
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-27 08:01:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ATT incorrect combinations in lohit pa fonts (1.61 KB, text/plain)
2005-03-18 02:25 EST, A S Alam
no flags Details
here is imge of those combinations (41.52 KB, image/png)
2005-03-18 02:37 EST, A S Alam
no flags Details
Patch for the font (293 bytes, patch)
2006-09-28 22:27 EDT, Rahul Bhalerao
no flags Details | Diff
Verified Image (1.50 KB, image/png)
2007-04-27 08:00 EDT, A S Alam
no flags Details

  None (edit)
Description Sukhjinder Sidhu 2004-12-16 21:56:36 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.5)
Gecko/20041110 Firefox/1.0

Description of problem:
Please note that I extracted the contents of the RPM on a Windows
machine and found these problems.  HOWEVER, this should not effect the
nature of the issues with this font.

The main issue is that it does not implement 'pstf' to create a
post-base form of Ya when entering Virama + Ya.  See TUS 4.0, ch9, p235.

Also, two simple additions of Adak Bindi and Visarg at U+0A01 and
U+0A03 would enable Unicode 4.0 support for the font.

Version-Release number of selected component (if applicable):
ttfonts-indic-1.6-1.src.rpm

How reproducible:
Always

Steps to Reproduce:
1. Enter Cons + Virama + Ya
2.
3.
    

Actual Results:  You will see the full form of Ya with a Halant (Virama).

Expected Results:  Post-base form of Ya.

Additional info:
Comment 1 Sukhjinder Sidhu 2004-12-16 21:58:37 EST
Looking at the font in FontLab shows that Lohit Punjabi includes the
glyph for post-base Ya, but it just isn't implemented.
Comment 5 Leon Ho 2005-03-22 08:21:58 EST
Aman has posted seperate problem to bug 151630
Comment 6 Leon Ho 2005-06-20 00:07:15 EDT
This should be fixed in FC4. Please confirm.
Comment 7 Sukhjinder Sidhu 2005-06-20 10:44:38 EDT
Nope none seem to be fixed.

Post-base Ya is not working nor are U0A01 and U0A03 added to the font.
Comment 9 Lawrence Lim 2005-09-05 20:54:42 EDT
Through the comment from Aman, this bug still exist as the new font package
still cant reproduce post-base Ya. (k + d + /) is the keystroke used.

The rest of the bugs in Comments will be split into individual bug reports.


Thanks.
Comment 12 A S Alam 2006-08-10 04:28:08 EDT
Paritial Fixed
1) (FIXED) 0A01 and 0A03 are included in bug
2) (NOT_FIXED) Original bug 0a15+0a4d+0a2f (Cons + Virama + Ya) issue is not
fixed in latest Rawhide 

Comment 14 Rahul Bhalerao 2006-09-28 22:27:37 EDT
Created attachment 137356 [details]
Patch for the font

Adds the GSUB rule for post-base YA.
Comment 15 Leon Ho 2006-09-29 02:58:36 EDT
Built in 2.0.5-1.
Comment 16 A S Alam 2007-04-27 08:00:20 EDT
Created attachment 153611 [details]
Verified Image
Comment 17 A S Alam 2007-04-27 08:01:20 EDT
Test is verified with following version:
fonts-punjabi-2.1.5-1.fc7

Note You need to log in before you can comment on or make changes to this bug.