Bug 143190 - Spamassassin (spamd) should run as non-root
Summary: Spamassassin (spamd) should run as non-root
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: spamassassin (Show other bugs)
(Show other bugs)
Version: 4.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Warren Togami
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-17 08:54 UTC by Milan Kerslager
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-28 07:34:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Milan Kerslager 2004-12-17 08:54:36 UTC
See bug #143189 for more info.

When spamd is run as root, config files (like Bayes database) are
inaccessible because they are in /root/.spamassassin and spamd
fallback to nobody.

Comment 1 Chip Turner 2004-12-19 23:11:23 UTC
those are root's configs.  normal users will use their own configs. 
what behavior are you seeing that leads you to suspect otherwise?


Note You need to log in before you can comment on or make changes to this bug.