Bug 143206 - /etc/init.d/autofs broken in LANG is not C
/etc/init.d/autofs broken in LANG is not C
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: autofs (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeffrey Moyer
Brock Organ
:
: 146754 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-17 07:50 EST by David Alden
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-20 03:08:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Alden 2004-12-17 07:50:24 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20040922

Description of problem:
When /etc/init.d/autofs starts up my automount daemons, the --timeout=600 in /etc/auto.master is being ignored.  I believe the problem is line 168:

if echo "$options" | grep -qE -- '\B-(t\b|-timeout\b=)' ;

If I set "options" to "--timeout=600", this returns false.  Thanks to a similar bugzilla report, I tracked it down to the LANG variable.  If I set LANG=C before I run /etc/init.d/autofs, everything works as expected.  If I leave it unset (default is en_US.UTF8), autofs doesn't get the correct --timeout value.


Version-Release number of selected component (if applicable):
autofs-4.1.3-28

How reproducible:
Always

Steps to Reproduce:
1. add "/fubar /etc/auto.fubar --timeout=600" to /etc/auto.master
2. start autofs: /etc/init.d/autofs start
3. ps -elf | grep auto.home


Actual Results:  [...]  /usr/sbin/automount --timeout=60 /fubar file /etc/auto.fubar

Expected Results:  [...] /usr/sbin/automount --timeout=600 /fubar file /etc/auto.fubar

Additional info:
Comment 1 Jeffrey Moyer 2004-12-17 09:30:08 EST
Thanks for the bug report.  We already have a fix for this pending.  I'll update
this bug when it hits rawhide.
Comment 2 Jeffrey Moyer 2005-03-01 17:52:27 EST
autofs-4.1.3-107 was built into rawhide, and contains a fix for this issue.  fc3
has a build pending.
Comment 3 Jeffrey Moyer 2005-03-01 17:53:21 EST
*** Bug 146754 has been marked as a duplicate of this bug. ***
Comment 4 Marius Andreiana 2005-08-20 03:08:02 EDT
autofs 4.1.3-114 is in fc3 updates. Closing as errata, please reopen if still an
issue.

Note You need to log in before you can comment on or make changes to this bug.