Bug 143209 - Slash (/) is not valid for model names
Slash (/) is not valid for model names
Status: CLOSED CURRENTRELEASE
Product: Red Hat Ready Certification Tests
Classification: Retired
Component: ispec (Show other bugs)
beta
All Linux
medium Severity medium
: ---
: ---
Assigned To: Will Woods
Richard Li
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-17 09:26 EST by Daniel W. Ottey
Modified: 2007-04-18 13:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-25 12:30:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel W. Ottey 2004-12-17 09:26:35 EST
Description of problem:
The slash character (/) is not valid for model names.  We enter our 
model name (ES7000/540) in the model field.  When we click submit, we 
receive an error writing the file.  I believe this is because it 
picks up the / as a new directory that does not exist.

Version-Release number of selected component (if applicable):
beta

How reproducible:
Enter a model name containing a slash (ex: ES7000/540) and submit 
your configuration.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 David Lawrence 2004-12-21 11:39:04 EST
Is this happening when you create the results rpm on the machine under test? Or
when submitting the results package to the hwcert web site?
Comment 2 Daniel W. Ottey 2004-12-21 11:58:08 EST
This is occuring when I attempt to configure the system on the ispec website (my
local server).

I am changing the Component to "ispec."  I now realize that "web site" is
actually for the web site where results are submitted.
Comment 3 David Lawrence 2005-01-06 15:23:57 EST
Verified with latest ispec package. Entering "Precision/340" instead of
"Precision 340" in the Model form field generates the error:

Processing... ERROR: Failed to create ../models/Precision/340: No such file or
directory
Please go back and fix this problem.
Comment 4 Will Woods 2005-01-06 16:33:02 EST
iSpec needs to change the model name into a valid filename. I've added some code
to safen the model name by replacing all unsafe characters (anything not
alphanumeric or [_.-]) with underscores. 

Are there any other weird characters that are likely to show up in model names?
Comment 5 Will Woods 2005-01-25 12:30:51 EST
fixed in iSpec 1.0.

Note You need to log in before you can comment on or make changes to this bug.